Callout LaTeX rendering bug

Steps to reproduce

Create a new note with a callout using “>”. Type it inside an inline LaTeX expression with anything in it. Move the cursor outside the latex expression but still inside the “>” callout block.
The LaTeX gets rendered correctly.
Now add in the first line of the callout any type such “[!done]”, and put the cursor back where it was before (anywhere outside the latex expression but inside the callout).
The LaTeX expression doesn’t render (it just shows the code as if the cursor was inside)

Did you follow the troubleshooting guide? [Y/N]


Expected result

The LaTeX expressions get rendered with the mouse inside the callout but outside of the “$” expression.

Actual result

The LaTeX expression shows as text (it doesn’t get rendered)


Obsidian version: v1.4.16
Installer version: v1.4.14
Operating system: #1 SMP PREEMPT_DYNAMIC Sat Sep 23 12:13:56 UTC 2023 6.1.55-1-MANJARO
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information


This is not a bug because it’s not supported:

And there is a feature request thread.

You can render LaTeX inside callouts using my plugin Better Math in Callouts & Blockquotes, but I hope it will be soon supported by Obsidian itself and I can get rid of this feature from my plugin.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.