Bullet Lists

I am simply trying to copy and paste a list from obsidian, into another sheet within obsidian.
The list/tab hierarchy goes all over the place when I do it?
I don’t understand why copy and pasting lists, shifts the lists themselves in some way!!!

Also how do I tab back a list? I can select the list and indent it forward and all items stay where they are supposed to be, but how do I revers this?

Finally, I am at the end of a list title, past the three dots. How come I can’t enter and get to the next line.

I’m not sure what you’re seeing, but if you have a lot of formatting, that may cause some shifting in Live Preview as the formatting marks are revealed when you select. If this is the problem, you can switch to Source Mode before copying (Note menu > Source Mode).

If that’s not it, it’s caused by a plugin or CSS snippet. Copy a list into the sandbox vault and try it there (the sandbox vault is found in the Help menu on Obsidian’s left edge on desktop; it doesn’t exist on mobile). If you don’t see the problem in the sandbox in Source Mode, the cause is a plugin or snippet.

If you still see the problem in the sandbox in Source Mode, I’m not sure what it could be. In that case it would help if you could post a screen recording.

You mean the edit mode? I am in edit mode. There are just so many little issues, they keep piling up. All the fucking youtube tutorials seem to completely ignore them. Obsidian seemed great to embed and take notes, but now that I have to transfer text/lists between files it’s turning out to be a piece of shit.

To clarify

  • I copy a list and move it somewhere else. If the list is more indented than it was then the title moves, but the children don’t shift with it - my list is then broken.

If I then take a single bullet point though it will not remember how indented it was in the original text and place itself where I tell it to. It behaves completely different to children.

If I take two bullet points at the same indentation leve and paste them - one will appear where I told it to, the other without indentation? WHY!!! Is there a way to get the bullet points - if they are at the same indentation level, to stay that way when I paste them somewhere else?

None of this shit seems consistent.

  • I am trying to use the outliner plugin - doesn’t seem to work to indent list and it’s children at the same time. Is there a hotkey to do this natively? Currently I have to close/fold the list and select the title and then tab it to move the list and it’s children. The plugin doesn’t seem to work for most things even though they are toggled on.

  • Sometimes when tabbing, some items move backwards, no idea why.

  • I get half lines when indenting - those vertical lines helping to visualize the indentation levels break-up. I also lose the bullets, they revert to dashes. The fuck is going there? I am guessing some extra space got in somewhere, but no idea how that would happen when all I did was copy paste the list. - Now that I look back this is likely due to first issue, I have to a list without indentation, otherwise, the title of the list moves, but the children don’t. fucking. follow.

This is costing me hours.

Have you tried in the Sandbox (Help/F1 -> Sandbox vault) as Cawlin suggested above? I would also try it without the Outliner plugin enabled in your vault and see how it goes. Their GitHub page has some issues listed, maybe something there? Issues · vslinko/obsidian-outliner · GitHub

1 Like
  • New issue - you’d think that highlighting the list dots … would highlight the list. Is there a way of doing this? Can’t say that it wasn’t a pain to figure out that highlighting the entire line would again fuck with the list indentation. Or that highlighting a list with bullets will open up all the lists for some reason and will not highlight all the bullets.

In this situation, it’s best to provide a screen recording, making things much easier to understand.

You can try the GitHub - jglev/obsidian-paste-mode: Obsidian Notes plugin for pasting text and blockquotes to the cursor's current level of indentation. to see if it helps.

I had the same frustration as you did. Now looking back it’s mostly me not understanding Markdown syntax.

1 Like

You’re better off using tools such as Notion or SiYuan, which provide a WYSIWIG editor. Obsidian is reserved for those who can tolerate

1 Like

pastemodes look helpful thank you!

actually doesn’t solve the issue.
As I said, all i want is to be able to paste a list and have it’s children follow the indent.
Should be able to do this.

Now just adding a dash suddenly fucks all the lists below why?

Because it’s a

glad we agree, love the help

OK, before trying anything else I recommend stepping away from the app for a while and taking 10 deep, slow breaths. (I’m not kidding.) Computers help us do lots of things faster, and and one of those things is “get upset”; it’s happened to most of us.

If you find yourself so upset you’re shouting and swearing, take time to calm down before posting.

Also helpful:

  • Start slow and simple.
  • Read the documentation: Home - Obsidian Help
  • Read and try the suggestions people give in response to your help request.
1 Like


Look all I want to do in this case is to be able to copy a list (closed) or several lists from one document and paste it into another all the while having the indentations of the children of this list and the children of the children and so forth, stay consistent inside the list.

Is this not possible? As soon as I tab, and then paste this copied list, the list breaks: the children don’t tab along.

I have tried all the modes in Paste Mode and nothing works.
It seems trivial, but not being able to do this means I have to be careful about pasting lists, and then tab them along one by one - not feasible for a large document. I mean this is what this software is meant to do at baseline…

Furthermore, when I paste a list, it pastes completely unfolded. No idea why.

Taking it back, I can’t copy a list that’s already got the title indented anywhere without breaking the indent. I’m sure this is super simple. I would appreciate an answer, there is nothing in any helpfile.

Weird thing is it works in one document better than another. Below is what I get if I paste the list

Whereas initially it was neat and tidy.

It’s not proper Markdown Syntax for indentation. That’s all that is.

this is what the list was before

I lost all bullets, including the numbered ones and oftentimes what was a child of one list becomes parent, no idea why.

Copy and pasting items shouldn’t destroy the parent-child relationship or the bullets…

There’s a “gap” here in the indentation. You need to outdent the “Site Disturbance”, and all its children, and you’ll see that it’ll be rendered correctly.