[Bug] "File does not exist" when picking an existing vault


[ ] iOS
[x] Android

Obsidian Mobile version: v1.0.2

Hello Obsidians,

I did sync my existing vault to my Android phone with the nextcloud Android client (which I use for all kinds of other things, too). However, when trying to access the vault, Obsidian complains that “File does not exist”, but without saying which file exactly.

I wonder if the path has gotten too long? Or does the app not have access rights to this particular directory?

Any ideas on how to remedy the situation would be appreciated!


Hey, joining in because I also have this problem.

I use Android.
I sync my vault to my phone through git (with a custom script).
The vault location is also somewhere in /storage/emulated/0/.
Currently I use Markor as editor, which has no problem opening the folder and files.

I also get this on android, using termux for git and using an emulated folder like above.

My vault is also located within /storage/emulated/0/

Obsdian cannot write in other apps private directory. @despens you can’t use nextcloud directory.

Folks, you have to be precise what exactly your path is.

I use Android and I have faced with the same error.
I’ve also made a new vault in my Syncthing folder via the Android app. The vault was created. As synchronization happened, I opened it on my laptop. Then I copied all my notes from the old vault to this new vault. As synchronization happened again, I saw my notes in the new vault via the Android app.
But then I restarted the Android app and faced with the same error again.

UPD: the solution is here [Bug] % and # symbols in .md filenames causes "File not found" error and hang when loading vault

1 Like

Thank you for pointing this out, @WhiteNoise !

Since other apps that I am using, like text editors or music players, can write to this directory, am I right to assume the Obsidian mobile app could be changed to do the same? If that’s the case I’d submit a feature request.

Thanks! This was the problem for me. I had one file with a #

We know that we have some issue with recognizing certain paths. If that is the case, it will get fixed. If the issue is that Obsdian can’t get direct write access to that folder (not some limited access mediated by Android API) it can’t get fixed.

Either way, a FR is not necessary.

I figured out that @vgm mentioned, one of my files names contained a bad character, in my case, a question mark.

After making a few tests it looks like if you keep #, %, and ? out of your file names, nextcloud can be used to sync vaults to Android devices.

Since android doesn’t support ? in filenames, why/how did nextcloud sync it?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.