[Bug] External Keyboard + Samsung Keyboard Problems: Delete Backwards and Page Jumps

I am an enthusiastic user of Obsidian and so I was very happy about the new release. But unfortunately I think I found a quite annoying bug that make using Obsidian nearly impossible.

The bug

For some words the backspace key deletes backwards. If I understand right, then insert mode would delete the next characters, but in my case the last character or characters are deleted. And only for some words.

Examples of the words deleted

  • rückwärtig
  • Plugins

Some similiar words like rückwärts do not make problems.

My set up

I use Samsung S4 tablet with Android. I installed quite some plugins and use minimal theme. The mistake only appears with the external bluetooth keyboard RK908, not with the onscreen keyboard.

What I tried to change it

I turned off all plugins and changed the themes (to stand theme and others). I restarted the tablet. I cleaned the cache from Obsidian. I deinstalled and re-installed Obsidian. I tried other vaults. I made sure that spell check is deactivated. I changed the language setting.

But nothing helped. Therefore I ask for help from you. Or some suggestions what else to try? If you need more information from me, then let me know. Thanks for you attention and help in advance.


Might relate to this issue

1 Like

Seems related to this issue: Some letter disappear - #3 by faysalforbd

This is similar to my issue here

Hi there, my companion in pain! :stuck_out_tongue_winking_eye: Did you find any solution for the problem? I am still trying and trying, and asking and asking many people, but nothing worked so far.


[ ] iOS
[x] Android

Obsidian Mobile version: v1.1.0

I’ve been experiencing some odd cursor jumping since the live preview update, this is the only recurring one though. For reference my devices are a Samsung I6 tablet and a Huawei EML-L09 phone

The first issue is that when I go to double tap space on either device, which with my keyboard settings replaces the first space with a period, the editor freezes for a split second, jumps the view slightly and deletes both spaces.

This seems to be recurring whenever I attempt any character replacement, on my android phone holding backspace usually deletes characters word by word, which in the obsidian editor results in the same freeze, shifts the view so the cursor is at the bottom of the screen, and quickly deletes and replaces the word.

Any help is appreciated!


This is problem tied to Samsung Keyboard and it’s not related to the other bugs.

I have experienced the same problem when using external keyboard (Logitech K380). It happens to show up in some lines and then it is sticky for that line. If I move to next line space bar continues to work as spaces. If I go to another program or browser the same is not observed. And as the original poster mentioned I have not observed this with onscreen keyboard only the external one which is a new purchase for me.

1 Like

It looks like this happens anytime I type a word that is not in English including acronyms like ITA or typos, space bar becomes delete key at that point for that line. I can move to a new line and continue.

1 Like

I use a Samsung S4 Tablet with an external bluetooth keyboard. Would it then be possible that the problem is solely tied to Samsung Keyboard. The problem appears not with the onscreen keyboard and with the external keyboard it only appears in the Obsidian editor, but not in other apps. Even in some plugins like Kanban and Excalidraw I can write without problems. Therefore I would argue that the phenomena is probably tied to the editor and some “unhappy” constellations.

I think you mixing crossposting on different thread confused me. Anyway, if you install gboard, does it happen?

Yes, you are right. And no, with Gboard it just works fine as far as I can oversee now. I test more in future. Seems that there is incompatibility between editor and Samsung keyboard or something like this. Now is already late, tell you later about more detailed testing results.

When you have gboard on, does the external bluetooth keyboard work fine?

I think so. Here is now midnight. After sleeping icheck

Spacebar becomes delete key when an external keyboard (Logitech K380) is paired with my Android tablet ( Samsung S6 Lite). This happens anytime a word that is not recognized by the dictionary is typed. My current workaround is instead of using space I put in a comma or - and then continue typing.


Additional datapoint I observed with the same keyboard connected to Android phone (Samsung S21 Ultra) similar behavior was not osberved. Only on my tablet so far.

Hi White Noise,
as I am writing this I use again the editor of Obsidian and wrote a text of about 350 words. And guess what? The strange phenomenon is gone. There is something wrong in the triad between my keyboard, Obsidian, and Samsung. But I also didn’t have any problems with the keyboard and my Samsung S8+. Thank you very much for your help. At last, now I can live, ehh write again.

1 Like

I had the same problem. Logitech K380 + Samsung S6 Lite + Obsidian. It works fine if I tipe in other apps or use the keyboard on screen.

I’ve tried using Gboard + external bluetooth keyboard and so far it seems to work just fine. Iˋll keep applying this solution and then come back here with feedback. Thank you for your help!

Having issues with Android virtual keyboards too, specifically Samsung Keyboard and Microsoft SwiftKey. On Samsung Keyboard I can’t even type, because the keyboard keeps closing despite me trying to type on it using stylus.
My device is Samsung Galaxy Note 20 Ultra on Exynos running latest firmware, Obsidian is up to date.

What do you mean by using gboard + external keyboard?