[Bug] Cannot open links with clicking with magic keyboard

Platform

[x ] iOS

Obsidian Mobile version: v1.1.1

I understand that the way to open links was revamped and that more changes to this are coming soon, but unless I’m misunderstanding something, the functionality does not work on mobile.

Expected: clicking on a link in Live Preview mode will simply open the link.

Actual: it does not open the link but moves the cursor there to edit it. It does not matter if my cursor was somewhere else, in an entirely different paragraph, or anything. I cannot open the note. Holding cmd and then clicking also doesn’t open the note.

Workarounds: if I open another note and focus on it, then if I simply click on a link in the previous note it opens it as expected.

Perhaps I’m missing something, but it seems to me something is off here…

It’s working for me (iPadOS 15.4, Obsidian 1.1.1), with both finger and mouse. Did you try disabling community plugins in case one is interfering?

Also, the release notes you linked to are for the desktop version (note the very different version numbers). The release notes for mobile are on the app’s page in the app store, where you can see for version 1.1.1 “Fixed clicking on links while editing not working, allow tap and hold to edit a link.”

Thanks, I tried disabling all the plugins but no luck. I’ve realized that it seems to work fine with touch, i.e. touching a link opens it. But when I click with the mouse it just moves the cursor to the link and starts editing it. Why would there be a difference between these two?

That’s strange. Are you using the default theme? I don’t think it should matter, but it’s 1 more possibility to eliminate.

What happens if you try to open the link the old way with the mouse (Cmd+click, I think)?

Some more things you could try, tho I don’t think any are super likely to help:

  • Clear Obsidian from memory (from the recent apps view, swipe it away). It has probably already been cleared at some point thru normal usage, but this way you’ll know.
  • Reboot the device.
  • Reinstall Obsidian (in case the installation of the update went slightly awry).

I tried deleting and reinstalling the app, and without the theme (Minimal) but no luck. I’m thinking maybe I’m misunderstanding something about how this should actually work?

To clarify, I’ve also realized that if the keyboard is not active, I can click on a link and it opens as expected. But if the keyboard is active, wherever my cursor is in the note, when I click on a link it just moves the cursor there. Cmd + click or even cmd + shift + click doesn’t do anything except move the cursor there. Maybe this is just the current functionality? Or does it work differently for you?

I tried with both finger and mouse, with and without the on-screen keyboard open, with a bluetooth keyboard connected, and with a Smart Keyboard connected, and tapping or clicking a link always takes me to the linked note. I didn’t try with an external keyboard connected and the on-screen keyboard open at the same time.

I’m sorry, I don’t know why it’s not working for you. You could try restarting the app after turning off plugins (to make sure they don’t have any parts loaded), and/or you could try rebooting the tablet.

I apologize for asking because it should be obvious, but are you definitely in Live Preview mode?

I am definitely in Live Preview, yes :slight_smile: This is very strange, I still have the sense that I’m just doing something wrong, will continue exploring… Thanks for the help

create a new empty vault. create two files. make a screen recording of the problem happening.

What is your iOS version?

Done. Created a new vault with only two files. I saved the vault in iCloud (not sure if that matters, but that’s how my other one is saved.)

You can see the video here: iCloud

You’ll see me clicking around trying to open the link, with no luck. If I change to preview mode, I can open it no problem. If I am in another note, I can also open the link. If I go back to the note, it won’t open.

iOS version: 15.4.1

what is your obsidian version?

How do you click? what is your input method?

Obsidian version 1.1.1
I am using an iPad with a Magic Keyboard and clicking with the trackpad

Does it work when you don’t use the magic keyboard? Unplug it.

It does! If I take it off the Magic Keyboard and just use touch to navigate, it opens the links as expected.

What could the problem be? Have others reported similar issues? Is this a problem for the trackpad in general?

I met the similar issue.
There is a workaround when this issue happens:

click+hold on the link will open the link

That does seem to work! Hopefully the bug can be sorted out soon so that’s not necessary.

Thanks for all the help.

My pleasure, :smiley:

I can’t seem to reproduce this issue on iPad with a magic keyboard’s trackpad. When I click on an internal link, it opens that note right away.

Weird, I’m not sure how else to demonstrate or reproduce it. The problem persists for me, though as @GLight mentioned, if I click and hold it will work as expected.

Is there any way you can think of that I can help you reproduce it?