[Bug] Black bar at bottom of window when activating Edit mode

[Bug] Black bar at bottom of window when activating Edit mode

Platform

[x] iOS (iPadOS 15.2.1)
[ ] Android

Obsidian Mobile version: v1.0.5


Hi! I’m on a 2021 iPad Pro 11" with the latest versions of iPadOS and Obsidian.

When activating Edit mode and placing the cursor into a document, a black bar of about 1" in height appears at the bottom of the window, underneath the mobile toolbar (moving the app up, rather than blocking part of the view).

When two documents are open in split view, with one in Preview mode and one in Edit mode, when I place the cursor into the document in Edit mode, the one in Preview jumps up by multiple lines or about 2".

Here’s a screenshot:

Thank you to both the developers and the community for your incredible work!

1 Like

I’m not seeing this in an internal build for 1.1.0, so it may already be fixed. Stay tuned!

I know this is old, but I get the same problem here

Additional info:

  • Obsidian v 1.2.1. (52), Installed through Testflight
  • iPadOS 15.4.1. running on iPad Pro 2018 11"
  • Community Theme: Minimal (but the same thing happens if the default theme is selected)
1 Like

Just to let you know, I’m still getting the black bar, with Obsidian up to date (1.2.0).

Again, thanks for your amazing work!

Platform

[x] iOS
[ ] Android

Obsidian Mobile version: v1.1.0


Hi, I am using the iPad version of the app with external keyboard, on iPad Air.

A problem I am having is that when I start to type, a black block will suddenly appear at the bottom of the screen. I am not too sure if this is a bug or a feature. There is no such problem if you don’t use an external keyboard.

  1. I can drag the ‘A’ button away, then the black block will disappear, and then if I type again, no such block will appear;
    RPReplay_Final1642818720-3
  2. However, if say I open the left-panel, then go back to type, the block will appear again;
  3. Moreover, if I open the left-panel when the block is there, the left-panel will ‘jump’. (So that sometimes if I click to fast, I will mistakenly click ‘open vault’ button instead of the setting button.)
    RPReplay_Final1642818720

In my understanding that black block is here because of the iPad’s (virtual) keyboard for autocompletion and voice input, etc.; or perhaps it is here to lift the main interface so we can touch the mobile toolbar.

Either way it could have a little improvement:

  1. I tried several different text/markdown apps on iPad, including Craft, Notion, Ulysses, iAwriter, etc., in their case whenever I start to type, the iPad virtual keyboard will automatically minimize, and there will be no black block appear at the bottom;
  2. Some of the apps I mentioned also have toolbars at the bottom, in their cases, the buttons are indeed lifted a little, but not that much; also, the background color is consistent. For example:

It is not really a huge problem, but it is a bit annoying. If it is possible, could we have this black block removed? Change the color so that it has the same color with the toolbar will also work. Cheers.

Same issue — I’d call it a bug, and I wonder if it’s not going to be left unnoticed unless it’s in the bug section…. It’s very distracting especially as I don’t use dark modes, so the black block is really jarring…

Same here, looks like a bug!

Same here, iPadOS 15.5. I have IA writer and Obsidian side by side, Obsidian has black bar, IA Write don’t: