BT keyboard language layout bug(Android)

I tried switching language layout on my keyboard whilest typing in obsidian but nothing changed.

I’m using Keychron k3 v2 for typing in mobile version of obsidian on Android. To swap between language layouts on android you use ctrl+space(as said in general settings), and it works in any app, but not in obsidian.

I’ve tried some combinations but none of them seem to work(ctrl+space/option+space/command+space/shift+command/shift+option)

I can’t find a way to solve that problem, i’ve searched for it but gained nothing, no similar information.

Same problem. Xiaomi Pad 6, Xiaomi keyboard 6. The hotkey “ctrl+space” doesn’t work only in Obsidian

Hello, I also have a Xiaomi Pad 6 (pro only), and I managed to solve the problem that this hotkey does not work, most likely it is intercepted by the browser, obsidian is a browser. In short, I changed the layout of the android and switched the language change to caps (this button apparently is not intercepted by the browser or the event is sent to the android after interception). The bad news is that it’s not just a method. I used this tool to remap the layout GitHub - ris58h/exkeymo-web: Android external keyboard remapping without root.

Found an actual solution. Now I can change lang at every app!!

Download from Google Store the “External Keyboard Helper Pro”. It costs 1.49$.

  • Select it as your current keyboard from Languages & Input menu.
  • Reboot your device.
  • Go to Languages & Input again.
  • Open “Manage keyboards” and choose “External Keyboard Helper Pro” to open
  • Go to “Advanced settings” / “Languages switching”.
  • Click on the "Language-switch key
  • Uncheck the “Disabled”
  • Choose Swift or Alt checkbox.
  • and finally use “Scancode” to choose your preferable key combination and click
    “SAVE” / I choose spacebar.

NOTE: This is a general problem and Xiaomi is aware of that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.