BibNotes Formatter: New Plugin to Export and Format Annotations from Zotero into Obsidian

Open the settings dialogue, choose “BibNotes Formatter” from the left pane and insert the path to your json file where the second red arrow points to. Important: I think you have to choose a relative path from within your vault, not an absolute one! Thus, if your json file is named, for example, “bibliography.json” and resides in a subfolder of your vault called “zotero”, the path inserted should be: zotero/bibliography.json

Thank you very much, @alltagsverstand

The problem is that, despite having typed the Path as appears in the screenshot and having the .json file exported from my Zotero in a specific folder in Obsidian, when I try to create a literature note, nothing appears on the list (I add another screenshot) even if I write explicitly one CiteKey. Which do you think could be the issue? Thank you very much in advance for your help!

@jayesta Some questions that come to my mind:

  1. What is “Pr”? Is it a folder within your vault?
  2. What is “Prueba plugin nuevo”? Is it also a folder? Maybe something is wrong with your export path?
  3. How did you export your json file from Zotero?

Hi, @alltagsverstand and thank you for your help:

  1. Yes, it is a folder within my vault.
  2. That is another folder within my vault where I would like notes to be stored.
  3. Right click on a collection, export collection, format: BetterBibTex JSON, Export Notes, Ok and store it on the folder which is stored in my iCloud.

Maybe the issue could be that I had issues when installing the BibNotes on my obsidian and I did it using the file from the last comment of this link. ¿Could it be that?

Thank you very much and sorry for the inconvenience!

OK, then let’s first check this:

1. Delete the complete bibnotes folder (in .obsidian/plugins)
2. Reinstall the plugin via settings / Community plugins
3. See if that works.


I completely forgot that the plugin is not in the community plugins list yet… Anyway, I would try to delete the folder, download the latest version and extract it again to your .obsidian/plugins folder. See if the problem still exists.

Hi again @alltagsverstand. I tried reinstalling the plugin, but I still have the same problem. No references appear when I click Create/Update Literature Note. Any other idea of what could be the issue? Thanks a lot for your help!

I don’t know what I have done, but now it works. I inserted the .json file in a folder which already had other files. Maybe that was the reason. Apparently, this is working well now. Thank you for your time! I’ll keep you posted on how this goes!

1 Like

Just replying that this is now working for me!

If you are using Zotero 6 and making your literature notes inside Zotero with the New Zotero 6 Pdf Reader and making highlights, annotations and image extractions then this plug-in is by far (!) the best one available today to import your bibliography metadata and notes into obsidian. It even let you import the image extractions into your obsidian vault.
The new Zotero iOS App is awesome and it lets you highlight, annotate and extract images on the go with your iPad very comfortably, all your notes are synched across all your devices.

Thanks for this awesome plugin!

1 Like

I have my settings set to make comments into blockquotes, and it works but if I have comments on highlights in Zotero’s native reader, the blockquote markdown (>) is added before the comment, but it does not go to a new line, making it so that the comment does not become a blockquote. Is there a setting I am missing to make this happen?

I agree!

There is just a bug with missing blank lines when updating, but otherwise this plugin is awesome for a zotero-obsidian workflow!

Hello, is there a way to activate it on iPad? I use obsidian on iCloud and bibnotes is installed on my Mac, working fine, but I can’t activate it in iPad, it just won’t let me press the button at community plugins tab

1 Like

Hi all, thank you @stpag for this plugin - it’s by far the best Zotero → Obsidian ref/note transfer plugin I’ve had the pleasure to use, even if it’s rough around the edges.

Update on TomcaT’s post - I believe the issue with the image import is due to Bibnotes looking for image files at the path of the PDF. When my PDF is stored in the original Zotero/storage folder the import works fine - it only breaks with external links and complains that the folder with the PDF doesn’t have the image file.

I think I found the bug and proposed a hacky solution until the dev has time to patch it: link

1 Like

Thank you @stpag for this great plugin.
I am on windows using zotfile for managing my pdf’s location in zotero, and I have the same problem with exporting image annotaion.

I noticed the file title does a cool thing when using the {{author}} variable, in that it summarizes the author names to “lastname1 and lastname2” for two authors, or to “lastname1 et al.” for more than two.

Is it possible to duplicate this behavior in the note template?

1 Like

Is there a way to modify the default template? I tried editing both the data.json and main.js files to no avail

What are your settings in “Update Existing/All Notes”? If “Only existing notes” is selected, the command “Update Library” will not create entries that are not already present in your vault.

Solved! Just saw the custom template option

1 Like

Hi @JamesKF,
This is a good suggestion and it is certainly doable. I’ve opened a feature request on Github (Add ZoteroID as placeholder in the template · Issue #100 · stefanopagliari/bibnotes · GitHub) and you can track the progress of this there