Backup your notes! (Do so automatically with Keyboard Maestro on macOS)

For everyone: this is a simple reminder that you should back up your notes. Cloud services are not a replacement for backups—in particular because changes to files synced to e.g., Dropbox or OneDrive propagate to the “backups,” too. Some of these services have quasi-backup features, like file rollback, but nothing beats the simple dependability of keeping a copy of your stuff somewhere else.


If you’re on macOS using Keyboard Maestro, I’ve created a simple macro that will create regular backups for you.

It is incredibly simple:
Every three hours, copy my notes directory to a folder on an external drive under a timestamp.

Screenshot:

Obviously, you will need to edit step 2/2 to get the files from your Notes and to direct KM to copy them to a backup directory.

Download it here.

12 Likes

I was about to post my macro for this same purpose yesterday!
I will do it now in another thread :wink:

1 Like

thanks @ryanjamurphy - super helpful.

1 Like

thanks @ryanjamurphy , I don’t have to manually rclone sync my markdown because of your sharing

1 Like

I have set up this Keyboard Maestro macro and edited the last part to target what to save and where, as well as editing the repeat interval. I then ran Try in Keyboard Maestro and it activated the backup successfully. However, it fails to complete subsequent backups. Keyboard Maestro gives the error message “file action failed because destination already exists. Volume…

It seems that the setting %ICUDateTime%yyyyMMddhhmm% isn’t correctly configured. Does anyone know how to fix this?

Hmm. It has worked for me for many months. Perhaps it doesn’t work when you use Try, but functions correctly when it runs as expected?

Unfortunately it fails in use too. Very strange, I suppose I could ask in the Keyboard Maestro forum and see if anyone has any idea what the problem is?

You could. Screen shot what you have here?

Here’s what I have.

Ah, you’re missing the variable in the second action. The path there has to include the backup date variable. So, append the following text to the To: line: /Backup %Variable%backup date%/.

Thanks Ryan that’s sorted it! Appreciate your help. Duncan