Apple ARM compatibility (Apple Silicon)

Adding my 2 cents. I have been following this discussion for awhile. I just picked up my MacBook Air M1 16gb and I can confirm that Obsidian works on this machine Big Sur with most recent system update 11.0.1 (20B29) !


Well…that solves that. Thanks!

Vanstar, can you take a picture a show us? Thanks. . . . .

Just to let everyone know (cross posted from Discord) that we’ll be making an arm64 release as soon as electron-builder supports building those.

Right know it seems that Electron has Apple Silicon support already, so we’re just waiting on the tooling chain to be updated (it’s being actively worked on) so that we don’t have to do a lot of repeated/unnecessary work.


On my Macbook Pro M1, Obsidian luckily opens and most of the functions work. (Discord could not open, Chrome opens but crashed randomly). The only bug is that I cannot copy and paste text inside Obsidian. So I had to do it in Typora.

Seems like Electron 11 supports Apple Silicon? I’m assuming that means native support and not through Rosetta 2?

@dwstevens yes, that’s literally written 1 post befere yours.

That’s great news! Do you plan to target Linux ARM64 (aarch64) as well? That would make my Chromebook and me very happy. :slight_smile:

So the v0.9.17 release notes state you have a native build, but I tried downloading it, and it stills runs as “Intel” on my M1:

Did I misunderstand something?

Maybe you installed the wrong version. Remove that and install the right one from here

Does removing and reinstalling M1 Apple Silicon DMG remove previous plugins, etc.?

No, it should not remove anything/settings/css. Plugins are writtein js and are stored in the vault.

Now what?

I knew that…:wink:! THANKS!

And your 2 for 2. Everything ‘returned’ after remove and reinstall.

Click Show in Finder then right click on file and click ‘open’. This will should help. I’ve encountered the same message and managed to open it with the method I mentioned above.

Maybe you installed the wrong version. Remove that and install the right one from here

Ah, I got it from the front page where a separate ARM Mac build is not indicated, so I got the regular one, thinking it would be a universal binary.

Just wondering if this is something that’s been resolved or not. I’m considering things as well and depending on if this app is usable or not would persuade me enough to wait or not.

Yes this is solved. we have universal binary now.