AppImage not longer working on Ubuntu 22.04

Hi folks,

Obsidian not longer starting on my Ubuntu machine.

Ubuntu 22.04
AppImage 1.0.0 freshly downloaded from website
Integrated in system with AppImageLauncher.
On startup I see a message in the UI:

“An error occured while loading Obsidian. TypeError: Cannot read properties of undefinde (reading ‘on’)”

Starting Dev Console shows:

TypeError: Cannot read properties of undefined (reading ‘on’)
at e. (app.js:1:2124972)
at app.js:1:235201
at Object.next (app.js:1:235306)
at a (app.js:1:234045)
(anonymous) @ app.js:1
app.js:1 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘isEnabled’)
at e. (app.js:1:2122635)
at app.js:1:235201
at Object.throw (app.js:1:235306)
at s (app.js:1:234096)

Starting the app from a terminal shows:

[email protected]:~/Applications$ ./Obsidian-1.0.0_809e6a4ec574449443bf5ca3de6d9b95.AppImage
2022-10-20 18:50:20 Loading updated app package /home/mckie/.config/obsidian/obsidian-1.0.1.asar
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[33655:1020/205020.763625:ERROR:sandbox_linux.cc(377)] InitializeSandbox() called with multiple threads in process gpu-process.
2022-10-20 18:50:20 Checking for update using Github
2022-10-20 18:50:20 Success.
2022-10-20 18:50:20 Latest version is 1.0.1 (insider)
2022-10-20 18:50:20 App is up to date.

I’m not sure if my problem is the libva error from the terminal or the javascript error from the developer tools.

I’m a Catalyst user and I’m unfortunately not quite sure, if before trying to make a fresh install there was a 1.0.0 or a 1.0.1 on the system. The AppImage 1.0.1 is, as far as I know, not available online.

Any hints on how to analyse this further?

Regards - Uwe

I would recommend to search the forum before posting:

Hi Uwe, it looks like there might be an issue with 1.0.1 on Linux.

In the meantime, I suggest rolling back to 1.0.0. That’s what I did (running on Ubuntu) and Obsidian is working fine for me. I have auto-updates turned off for now.

I did search for the error messages in UI and console. The original poster provided a screenshot. That’s the reason I always provide the error messages as text, to be found easier. Thanks for your suggestion though.

Regards - Uwe