Android/Samsung Board: Return/New Line key not working

Steps to reproduce

  1. Uninstall and reinstall Obsidian app from Google Play
  2. Create a new vault
  3. Create a new note
  4. Type “hello” and leave the cursor after the last letter without a space
  5. Press the Return key

Expected result

Cursor will move to next line

Actual result

Cursor does not move.
The keypress event itself is recognized (the Return key changes highlight color) and the word “hello” is now underlined. I have auto-suggest on and it shows alternate words. Turning off auto-suggest does not fix the problem and cursor is stuck at and of the word.


Samsung S22,
Android V13
One UI version 5.1

Additional information

Putting a space after the word will allow the cursor to move to the next line, but this is a hacky and unacceptable workaround.

This bug has been recently reported on Reddit
and one user suggested using GBoard, again an unacceptable workaround.

I think this is an Obsidian bug because I don’t see the problem with other text editors running on my Android.

I also have this issue, but it seems intermittent for me. Maybe the space at the end was the differentiating factor when it worked vs when it didn’t. Either way it’s been like this for at least one or two versions.

Also on a Samsung (s21) fully updated.

Please post a screen recording on a vanilla vault.
What is your Samsung board version exactly? I can’t reproduce on v5.6.10.31.

A post was merged into an existing topic: Android/Gboard: Can’t create new line in notes (Return/Enter)

Everybody having this problem please provide

  1. you phone make/model
  2. the samsung board version.
  3. a screen recording of this happening in a new vault.

is this still happening on samsung board with Obsidian Mobile v1.4.4 build 99+?

Having a similar issue on a Google Pixel 6A. I especially notice it when making a bulleted list. The expected behavior is return once to start a new bullet, return again to delete the new bullet, but it only behaves this way intermittently… sometimes a return will just start a new line, without the bullet.

That’s a different issue tracked in a different thread.

I can confirm the issue is solved now.

My Device: Samsung Galaxy S20+ (with both Samsung Keyboard and Google Gboard)

Also happening in moto stylus 2022

Same issue on Fairphone 4.

Quite annoying.

Android 12. Version:

Obsidian 1.4.3 (95) api v 1.1.16

Screen recording on fresh vault attached. Rename the file, upload of mp4 is forbidden. This is not a real zip, I just added the extension to get the upload done on android despite forbidden mp4 upload. (3.8 MB)

I’m also affected by this bug.
Using GBoard.
If I type say letter “s”, it becomes underlined. Afterwards, I cannot get a newline when tapping the Return key.

Samsung: S21
Android: 13

Please, there is a separate thread for gboard, use that.

Is this still happening with samsung board on v1.4.4?