Anchor link not working on somes header

Hello my config :
Mac mini m1 ventura 13.4.1
SYSTEM INFO:
Obsidian version: v1.3.7
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.5.0: Thu Jun 8 22:22:19 PDT 2023; root:xnu-8796.121.3~7/RELEASE_ARM64_T8103 22.5.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: AnuPpuccin v1.4.4
Snippets enabled: 10
Restricted mode: off
Plugins installed: 70
Plugins enabled: 57
1: Outliner v4.8.0
2: Dataview v0.5.56
3: Tag Wrangler v0.5.11
4: Kindle Highlights v1.9.2
5: Better File Link v1.1.3
6: Find orphaned files and broken links v1.9.0
7: Hover External Link Plugin v1.0.0
8: Natural Language Dates v0.6.1
9: Theme Picker v1.0.8
10: Timestamp Notes v1.0.8
11: URL Namer v1.0.1
12: Advanced Tables v0.19.1
13: Diagrams v1.5.0
14: TimeStamper v1.3.0
15: Note Refactor v1.7.1
16: Checklist v2.2.12
17: ReadItLater v0.3.1
18: Highlightr v1.2.2
19: YTranscript v0.8.2
20: Readwise Official v2.0.1
21: Excalidraw v1.9.16
22: Antidote Grammar Checker Integration v2.1.2
23: Hover Editor v0.11.13
24: Auto Link Title v1.4.1
25: Projects v1.16.3
26: Omnisearch v1.15.2
27: Multi-Column Markdown v0.8.3
28: Extract url content v0.12.1
29: Tracker v1.10.9
30: Style Settings v1.0.6
31: Icon Folder v2.1.2
32: Banners v1.3.3
33: Editing Toolbar v2.3.1
34: MySnippets v1.2.3
35: Quiet Outline v0.3.15
36: Advanced URI v1.37.0
37: Homepage v3.4
38: Callout Manager v1.0.1
39: Metadata Menu v0.5.1
40: Mind Map v1.1.0
41: Emoji Magic v0.2.2
42: Templater v1.16.0
43: Full Calendar v0.10.7
44: Day Planner v0.5.8
45: Calendar v1.5.10
46: Periodic Notes v0.0.17
47: Rollover Daily Todos v1.1.6
48: Enhancing Mindmap v0.2.5
49: obsidian markmind v1.7.7
50: QuickAdd v1.2.1
51: Global Search and Replace v0.3.0
52: Obligator v1.2.0
53: Recent Files v1.3.7
54: Waypoint v1.4.0
55: Custom Frames v2.4.6
56: Text Generator v0.3.20
57: Smart Connections v1.6.34

What I’m trying to do

Hello,

I trying to link certains header from note in another note, to do this I use the [[filename#name of the header]].

But, certain of the header H1, H2, etc works and others don’t and I need help about this, I have searched too on this forum, but I haven’t found an answer that fit my my lack of understanding

Things I have tried

  • Putting an underscore between the title’s words
  • Removing the dot between the p and the number pages on the header
  • Removing the page’s number in the header
  • tried to reproduce the action on the sandbox but the error remain

I put here a link, where I have filmed what’s I explain here : kDrive

Thank’s you for your help.

It looks like accented characters might be breaking the links. (I’m not rewatching the video to confirm — more helpful than a video would be examples of links that do and don’t work, pasted them here and marked them as code).

If that’s the case, it sounds like a bug that should be reported (make sure to follow the instructions in the bug report template).

Hello,

Damn, it’s true, it’s the accented characters

Links tha's work
[[S14 Actions & Coopération#VIDEOS]]
![[S14 Actions & Coopération#CARNET DE BORD]]
![[S14 Actions & Coopération#**CONTENU**]]

Links that aren't working
![[S14 Actions & Coopération#**TABLE DES MATIÈRES**]]
![[S14 Actions & Coopération#Réunion opérationnelle p. 278]]
![[S14 Actions & Coopération#Séquence de réunions de sprint agile p. 283]]
![[S14 Actions & Coopération#Réunion de planification de sprint p. 286]]

But for this link ![[S14 Actions & Coopération#Références]], where there is accentued charcaters, works meanwhile, there's is nothing in it, very strange....

I hope this help and I will report as bug, Thank you CawlinTeffid.

1 Like

Actually, I tried writing a heading with an accented character and was able to embed it, so there must be something more to it. :thinking:

Oh, I see you have one that works too. Strange!

I see that the one that works for you has no punctuation (# or .) but I am able to embed with those too.

Did you copy-paste the heading text from elsewhere? Maybe there’s a hidden character causing a problem. You could try rewriting one of the broken ones manually and deleting the original heading.

Also, since all the broken ones are embeds: if you remove the ! do they work as links?

I have tried something,

I have removed all accentued characters in a link and the link’s embed work, then I have put again the accentued characters and the link embed works.
I have close Obsidian and reopen and the embed link’s are worked.

It’s like to create a first path, that’s allowed the accentued charcaters works now ?

I don’t copy them, I have rewriting one by one.

Yes the links works, removing the !

Mysterious! But I’m glad you solved the problem.

It’s a temporaly solution for me, because I have a lot header with accentued characters.