After importing Joplin->Obsidian some images are not displayed


I would like to switch from Joplin to Obsidian to try Obsidian but I have a problem with SOME images attached in notes.
Joplin stores all note images in a folder called “_resources”.

I have imported the .md notes and the _resources directory (which contains all the images) into my vault.

When I open a note some images from that directory are shown but others show me the message: “the attachment is not created yet”

Image is showed:

Image doesn’t show:

Things I have tried

So I have done two things:

Settings => Files and Links =>
Default location for new attachments: In the folder specified below.
Attachment Folder Path: _resources

But the same thing happens, it shows me some images and not others.

What I’m trying to do

What could I try more?

Thank you!


I already know where the problem is, the problem is that for example, the images that are not seen contain spaces.
When entering Joplin’s note to Obsidian, it shows me the images in the md file like this:

![Screenshot (55).png](../../_resources/Captura de pantalla (55).png)

On the other hand, if I add a “%20” in the spaces, then the image is shown, leaving the line like this:

![Screenshot (55).png](../../_resources/Captura%20de%20pantalla%20(55).png)

But doing this on all the images in my notes is embarrassing.
Is there any way to change space to %20? What can I do having localized problem?

Search the forum — this has come up recently.

Thank you! But topics that I found doesn’t work for me :frowning:

Nothing here helped?

EDIT: One of those solutions is for Evernote and the other is a shell script, which is technically a solution but also a hassle.

Does anything here work?

One of the original solutions that the poster tried sounds like it worked but left out the front matter — if you don’t have front matter, then maybe it’s good enough.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.