Imported notes with file names containing spaces

Things I have tried

What I’m trying to do

New to Obsidian here; fleeing Evernote. Exported to ENEX, then used Joplin to convert, then loaded up into Obsidian. Overall, process worked well, but with one exception. Many of Evernote’s saved files contain spaces in the file name. The import process created links with the following format:

![Image name.png](…/_resources/Image name.png)

I’ve moved the _resources folder to the correct location. The problem is the space in the file name. I can swap it out for a %20 and it fixes it. The problem is that I have hundreds of such files linked across hundreds of notes.

Any ideas how I can fix this? Manually editing all the paths is infeasible. I do not have the skills to do this programmatically.

Any help appreciated. Thanks.

@ArchieOnt wrote a shell script for that today!

Obviously backup first if you try it, and maybe test it on a copy of a few notes first.

1 Like

Wow! What are the odds?! This is cool. Unfortunately, I don’t know how to run a script, but this is a start…

Hi!
If you would like to, you can try my desktop application that converts your notes from Evernote to Markdown with full support of Obsidian: GitHub - akosbalasko/yarle: Yarle - The ultimate converter of Evernote notes to Markdown

Cheers,
akos

Basically you save the text into a text file (conventionally with the suffix .sh), make the file executable, then use a terminal program to run it. If you’re on Windows you’ll have to enable Windows Subsystem For Linux first, which may be more rigamarole than it’s worth for a 1-time use.

Whatever system you’re on, @akos0215’s solution seems like a more comfortable place to start.

Whoa, I’m gonna check this out. Thanks!

Thank you so much for explaining this to me!

So the fact that YARLE exists is fantastic! I really appreciate it. It’s working very well. I am running into one issue though: none (absolutely 0) of my tags are preserved. I have fussed with the front matter formatting every way I can think of. Many of the notes also have a “INVALID YAML” error at the top when in view mode. If I go in and manually edit the YAML, I can get the tags to work, but only if I remove the other contents (the time-stamps).

Am I missing something? Can YAML only hold the four items described here: YAML front matter - Obsidian Help ?

It sure would be nice to be able to keep both tags and time-stamps. Any help would be appreciated.

Still puzzling through this…I found that if I put a # in front of every line of time-stamp material, Obsidian will read the tags. All other configurations either eliminate the tags or make them unreadable. I may go with this solution, but I’m curious to know if this is expected behavior. Thanks!

Ok, I discovered that if the following conditions are met, Obsidian will correctly read tags in the YAML:

  • Each line in the YAML must not have any leading spaces
  • Each line in the YAML must have some text followed by a colon followed by more text (or at least a space)
  • The tags cannot contain a leading # (tags formatted as such within the body of the note are read as tags, but tags in the YAML must be designated as tags only be the preceding text “Tags:”)

So after I edited the template in YARLE to meet those conditions, it worked.

Once again, @akos0215 , thanks so much!