A part of the text to the left of the cursor is removed from the headers when editing headlines

Steps to reproduce

If you select multiple characters in the title and start making corrections. Or if you just put the cursor in the middle of the title, and start typing a new word.

Expected result

I expect it to be done.

Actual result

At this moment, for some reason, part of the text is removed (from the cursor before the start of the line).
After Pressing Ctrl + Z, The Text Returned, And The Error Is Not Repeated.


  • Operating system: Windows 10
  • Debug info:
    This does not work.

Additional information

Test 22-04-08

I would also like to add that I have encountered errors from this thread: Random horizontal lines appearing mid-text. I also came across this problem «Random horizontal lines» in a wide variety of notes. She met in notes containing more than 35,000-40000 characters. And she disappeared if this note is closed, and then open it again. I also encountered a mistake of scrolling long notes at which the note was not scrolled to the end, but suddenly returned to the beginning of the text. A similar error I also met in Chrome browser when watching long pages.

At the specified reasons, now I try to make notes a length of less than 35,000 characters.

Can you post a screen recording of this happening in the vault and attach the debug info.

Recording the screen about this event I attached to the first message. This is spontaneously, and not repeated in the same place. For several days I tried to catch and write this screen record to post it on the forum. Additionally, I can tell the following. It is not very often occurring, about one of 10-30 cases editing headlines. This error is observed on my computer and on my laptop. These computers are installed completely different programs that are just the same versions of the operating system. And the problem does not disappear if you enable secure mode. And I was rewritten with one user, who said that he has the same program errors.
I will try to get Debug Info later. Since now I am not near the computer.

I can’t reproduce in the help vault. If you do find reproducible steps, let us know.

This problem, like the one, which was described by other users in the “Random Horizontal Lines Appearing Mid-Text” theme - they appear in completely random places, and when you repeat all the steps, these errors for some reason are no longer repeated. I can still add that they are usually observed in large in terms of the volume of notes, where several partitions are minimized, there are several levels of headers, tables and attachments.

I just experienced an experienced way that this error is present only in “Live Preview Mode”. In the “source mode”, this error is not.
Is there a way using CSS, to make it so that the characters # in the headers did not hide in the “Live Preview” mode? Perhaps this error is related to the dynamic status of the headers. I would check such CSS, and wrote a result here. I tried to find it on the forum on my own. But, because I’m just going to start learning English into one of the next Mondays, I could not find the appropriate option.

I found the right code there: obsidian-css-snippets/Headers.md at master · Dmitriy-Shulha/obsidian-css-snippets · GitHub
But even after that, the problem persisted.

  1. I select some characters.
  2. I press any keys
  3. In this case, not only the selected characters are deleted, but also part of the line.

Test 22-04-08 2

Obsidian version: v0.14.2
Installer version: v0.13.30
Operating system: Windows 10 Pro 10.0.18363
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: on


Can you reproduce this problem in the help vault?

Are you using some custom imput method?

Test 22-04-08 3

TestFile.md (1.8 KB)

thank you very much. I can reproduce.

I just created a new empty repository.
Created a single note in it.
The result is attached to the post above along with this note.

I can reproduce the problem as well.

will be fixed 0.14.8

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.