Zotero Integration "unexpected end of JSON input"

What I’m trying to do

Get Zotero Integration to create notes.

  • When I try to create any kind of import format (e.g., "Zotero Integration: Import #1) it successfully opens Zotero, lets me choose an article, but when I press ‘enter’ to import it, it flashes this message “Error retrieving item data: Unexpected end of JSON input”.

  • It does work when I use the default setting (“Zotero Integration: Import notes”), but this creates a blank note with the citekey as its title, and its only content is Zotero’s note (so no article title, authors, publications, etc)

Things I have tried

  • changing the directories it imports into (the base site or subfolders)
  • Adding and removing a citation format
  • 2 different templates (found on the web) and also no template
  • creating a blank new import format and not changing any of the options
  • Googling it (I found one thread with that error message, but they said it went away after something updated… But I have auto updates turned on already)

Note: I have Pandoc Plugin and Pandoc Reference List installed. These seem to work fine (when I insert {@article_year} into a note this is replaced with a correctly formatted entry.

Looking for help

That error message indicates that there are a mismatch on braces in your import format. So in order to help you it would be beneficial to see the import format which fails.

Be sure to include it with a set of four backticks, ```` before and after the import template, so it’ll not be visually damaged when viewed in the forum post.

It actually indicates that Zotero Integration needs to be updated to be compatible with the latest API changes from Better Bibtex. See:


I am such a noob!

I had assumed that auto-updates being on meant that everything was updated already! I forced an update by deleting the plugin and reinstalling it, which worked.

Then discovered the “check for updates button” - DOH.

Yay thanks!

1 Like

I was having the same problem and going around in circles. Just a simple solution, Update the plugin! Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.