Zotero Integration: Error Loading Template

What I’m trying to do

Hi, I’m trying to import a template from Zotero that worked before, but now I am getting two error messages:

“Error: template not found (location/name of template)” and “Import failed for (note), check developer console for details.”

I tried to import multiple files from Zotero, and I get the same message.

I had dealt with the previous JSON error that several people had and corrected it by updating Zotero Integration in Obsidian. It was working well again for a while, and now it stopped working.

Any idea what could be causing it? I can’t think of anything I did to change it, except perhaps download some extra community plugins.


Did you by any chance move the template or rename it? Can you share screenshots of your import format settings, and of your template folder?

Hi, Thank you for the help!

I didn’t move or rename the template.
Here are the screenshots of import format settings.

Here is the setup on the dashboard:
RschNoteProblems_Screenshot 2024-01-20

Here are the settings in the Zotero plugin:

Here is the template for Zotero:

I did not setup the template. I downloaded a vault created by someone else: GitHub - erazlogo/obsidian-history-vault: A starter vault for historical research with Zotero and Obsidian.. I added the last part of the template “Analysis” to the pre-set template for myself, which didn’t seem to be an issue before. Plus, it still doesn’t work when I take it out.

Could it be a Zotero issue? Do I need to update or change the BibTex plugin in Zotero? I also don’t see BibTex as a community plugin in Obsidian. Could that be an issue?


No template is set in your import format settings.

Oh that fixed it! Thanks very much! Not sure how that happened, but glad it was a simple fix.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.