Zotero Data Explorer says I have 0 annotations

What I’m trying to do

I’m trying to import highlights and notes I’ve made on a pdf in Zotero

Things I have tried

I’ve installed better bibtex and the zotero integration plugin in obsidian and I’ve copied code I found on the forums here for a template, and when I use Zotero Data Explorer it always says that the file I’m trying to pull annotations from has 0 even though I have several. I am going to include a screenshot of what it looks like in obsidian

1 Like

I think something similar happened to me. For some reason, mine was resolved from updating all community plugins & themes.

I don’t know enough to evaluate whether your template is causing issues, though.

I copied it off of someone else on here who said it works but the same thing happened with Danny Hatcher’s template (youtuber who has a video about Zotero integration)

I know you said you’re using the data explorer, so is it safe to assume you have tried importing an article with annotations from your zotero library? Did it spit out any error codes in the top right corner?

No, at one point it was giving me “Error converting formatted bibliography to markdown” but I managed to make it go away by changing the export options in Zotero
Are we sure Obsidian can import highlights as annotations from Zotero at all?

It does work for me, and I use Danny Hatcher’s template as is. What else have you tried?

I changed the Zotero Export options from markdown+rich text to html to see if it would make a difference but it didn’t.
I also tried exporting notes from another file thinking that it might have something to do with this specific pdf but it yielded the same result.
I have updated all plugins and themes on my Obsidian and my Zotero has only Better BibTex as an addon so nothing else could be interfering there.
I tried several different note templates to no avail.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.