Zettel ID format doesn't allow a space at the end

Steps to reproduce

  1. Go to Settings > Core Plugins
  2. Enable Zettelkasten Prefixer
  3. Go to Core Plugins > Zettelkasten Prefixer
  4. Change the Zettel ID Format to "YYYYMMDDHHmm - " (without quotation marks)
  5. Exit Settings
  6. Press the “Create new Zettelkasten note” button

Expected result

Note title begins with "202104041921 - " (no quotation marks), with a space at the end.

Going back to Settings > Core Plugins > Zettelkasten Prefixer shows Zettel ID Format as "YYYYMMDDHHmm - " with a space at the end.

Actual result

Note title begins with “202104041921 -” (no quotation marks), with no space at the end.

Going back to Settings > Core Plugins > Zettelkasten Prefixer shows Zettel ID Format as “YYYYMMDDHHmm -” with no space at the end.

Environment

  • Operating system: Windows 10 Home (OS Build: 19042.867)
  • Obsidian version: v0.11.9

Additional information

Substitute your own date and time for the expected result and the actual result, of course.

Some other things I’ve tried, no space showing at end:

  • “YYYYMMDDHHmm[ - ]” → “YYYYMMDDHHmm[ - ]” when returning to Settings > Core Plugins > Zettelkasten Prefixer.
  • "YYYYMMDDHHmm -\ " → “YYYYMMDDHHmm -\” when returning to Settings > Core Plugins > Zettelkasten Prefixer.

This is a very minor thing and I am not sure I consider this a bug. Open a feature request.

I strongly disagree. If you put a space at the end of the line in settings it’s expected that it would keep the space at the end.

Please explain how this can be considered a feature request?

Bug or feature or not, I won’t answer to that. But I’m curious why you want this dash and spaces? Can you explain further what you are trying to accomplish? Maybe a workaround can be found.

If this worked, this would result in your filenames being “YYYYMMDDHHmm - .md” That seems unintended. Are you instead trying to simplify a part of a workflow you didn’t mention?

Your filenames could be “YYYYMMDDHHmm” without the dash at all, but your heading at the top of the body of the note could use "YYYYMMDDHHmm - " by using the template plugin.

Or was it that you are later wanting to add a description to your note’s title in that space?
example: “YYYYMMDDHHmm - insert more here”

It seems like I was a little confrontational there. I’ll make a new suggestion thread if necessary.

It sounds like you don’t want to get involved in categorising this.

The idea is to add in the note title after that, the space would be there so I don’t have to type a space after the dash every time I create a new Zettelkasten note.

"YYYYMMDDHHmm - "
“YYYYMMDDHHmm - my note title here”.

I’ll take a look into the template plugin, though it does feel a bit overkill to just add a space on the end when we already have a button to create Zettelkasten notes.

I figured you were annoyed to type a space before start typing the title. The function we use trims whitespaces for consistency. I don’t think we are gonna change it but feel free to open a feature request.