Yaml frontmatter didn't convert to Properties

What I’m trying to do

When properties were introduced in Obsidian 1,4 most of my notes with YAML frontmatter converted to properties in the Live preview mode. However, I have quite a few that did not. I have tried to find a way to convert them with no success.

Things I have tried

I have searched on the title above; also on How To convert … ; The only solution I have found is to manually recreate the frontmatter using the Properties command. This, of course, requires not only selecting each property but also manually entering (copy/paste) the information for each.

Hopefully, there is someone who can offer a much simpler solution to this. I am sure I am not the only one with this situation and am puzzled at not finding it addressed somewhere in the forum.

Thanks for any help.

Yaml that is properly formatted automatically will be interpreted as frontmatter. For those notes where that is not the case, you have a formatting issue. If it is a systematic error, there is the possibility to correct it by global/replace. If it are specific errors, they will have to be corrected manually.

1 Like

In the post below I show a query which might help you locate the offending frontmatter sections at least. This way you can focus your efforts on which files have bad yaml, and hopefully you’ll start seeing a pattern of what to change to make the yaml valid, which in turn will automatically make it into properties.

The post above should also be the answer to Query for notes with invalid YAML? (which has closed recently), but where a similar question where asked by @chrisdwells and @joshuawagner .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.