X (Former Twitter) embeds

I experienced this problem using the Windows version of Obsidian. I have an AMD Ryzen 7 6-core chipset running Windows 11.

There’s a bug in the embedding of X (Formerly Twitter) posts. The feature works very well, but apparently there needs to be a change in the next update.

The feature properly works when the link is in the following form:

![](twitter.com/USERNAME/status/POST-ID)

But as X transitions away from links being associated with the twitter.com URL, the link copy feature in the post share method is now producing links with x.com. I was recently copying one of those links and was surprised that the Obsidian program didn’t draw down the pic using the following format:

![](x.com/USERNAME/status/POST-ID)

So I changed the link from a URL base of x.com to twitter.com and it worked just fine. I’ll keep doing that for now, but looks like you need to update the program to accept either URL for embedding purposes.

Thanks

3 Likes

thanks

Note: After Twitter’s name changed to X, the new links generated while sharing or embedding tweets start with https://x.com/ instead of the old ones https://twitter.com/.

Embedding tweets with older links works fine, but they don’t embeds don’t work with the x.com links. (Screenshots attached below)

Steps to reproduce

Step 1: Copy any new tweet URL to the clipboard.
Step 2: Use that URL to embed the tweet in Obsidian using the method: ![](https://x.com/0xsunil/status/1737387658572365926?s=20)
Step 3: Notice that this embed does not work properly and will show a broken image.
Step 4. Replace the domain in the same URL from x.com to twitter.com. Example: ![](https://twitter.com/0xsunil/status/1737387658572365926?s=20)
Step5: Notice that the embed works fine now.

Note: Twitter has not disabled https://twitter.com/... URLs for older tweets. So, if you share an older tweets, the links generated still start with https://twitter.com/..., but since most people will save newer tweets, they will see broken embeds.

Did you follow the troubleshooting guide? [Y/N]

Y.

Expected result

Tweet embeds should work the same whether it is a https://twitter.com/.... or a https://x .com/.... url.

Actual result

Tweet embeds work when I use a https://twitter.com/.... URL but not when a https://x.com/.... url.

Environment


Additional information

Error with https://x.com/... URL
image

No error with https://twitter.com/... URL

1 Like

Did you search before posting?

Yes, Didn’t find one discussing this issue.

Hoping for a solution to this. Swapping the domain name in the URL manually isn’t a big deal for me because I don’t embed tweets in Obsidian all that often, but it does slow down your workflow.

wow, I’m shocked that this is STILL NOT FIXED after many months…

Will be fixed v1.7