WYSIWYG bug with in-text footnotes

Steps to reproduce

[E.g., in Editor Mode]: John Doe reported: “it’s just not right”^[Doe, J. (2020), p. 50]

Expected result

As per everything else with the new editor, you expect the markdown to be converted to WYSIWYG once you click out of the markdown text. For example, if the example given above was the first citation in a document, you’d expect it to change to a [1], as it shows in ‘Preview Mode’. Everything else works like this, so I can only assume this is a bug.

Actual result

Remains as ^[Doe, J. (2022), p. 51] instead of ‘[1]’ once clicked away.

Environment

  • Operating system:
    MacOS Ventura
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 22.2.0: Tue Nov 8 21:14:19 PST 2022; root:xnu-8792.60.55.131.1~1/RELEASE_ARM64_T6000 22.2.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 11
    Plugins enabled: 5
    1: Advanced Tables v0.17.3
    2: Templater v1.11.3
    3: Paste URL into selection v1.7.0
    4: Recent Files v1.3.2
    5: Dataview v0.5.47

1 Like

Please, try to search before posting.

My apologies. I did a quick search and missed that post. I think I accidentally only searched within ‘bug’ category.