Writing in french, accents are considered as markdown symbols!

I got a question regarding the ‘ symbol. When I am writing in french there are many words that start with ‘ as an accent above some letters (ex. écrire). However whenever I insert the ‘ symbol at the beginning of a new word Obsidian automatically considers it as a markdown thing (I have no idea what it means) and adds two ‘ ’ then it inserts the cursor in between these two symbols.

I tried to turn off Markdown automatic conversion from the Editor, but the issue persists.

P. S. I am working from iPad.

No one can help me in this issue, it’s so annoying.

that’s an easy one. write \` instead.

the same goes to other markdown symbols like [ or #. just write \# \[ instead.

edit: it seems there has been some misunderstanding. but if you want to write é I’m not sure what’s the problem, because when I paste this letter into my Obsidian md file, it shows up accordingly.

1 Like

[1]

You may want to try disabling auto pair markdown Syntax option in Editor settings.

[2]

Regarding é, ì, û, ô, à, etc, on IOS, (I do write in Portuguese every day):

  • The IOS keyboard solves that, if you long press the letter
  • You may want to try adding the French keyboard, if you haven’t yet

Hope that helps :slightly_smiling_face:

2 Likes

Both proposed solution didn’t work.

Comment fait tu t’es é sur ton clavier? Une seul touche é ou en deux touches ‘ + e?

J’utilise majoritairement mon mac je vais regarder si il y as quelque chose à faire sur iOS.

Tu écris avec un clavier externe?

Hey! I have the exact same problem, I use a QWERTY U.S. international keyboard on an iPad and usually type accented letters by typing first the accent, then the letter:

’ then e => é
` then e => è
" then e => ë
^ then e => ê

The problem occurs for the symbols ’ and " when the accented letter is at the beginning of a word (except if it’s the first letter of the paragraph). For instance writing “Test [accent then e]” results in:

Test ‘é’
Test è
Test “ë”
Test ê

Hope this helps! Any help would be appreciated.

Edit: I believe this to be a bug. Maybe this should be posted in a the bug section of the forum?

I’m not suggesting this shouldn’t be posted as a bug or not. I don’t know.

But as an alternative workaround, the way that I’ve always typed accents is by using alt/option key:

alt+e then e = é
alt+e then a = á
alt+e then o = ó (etc…)

alt+i then e = ê
alt+u then e = ë
alt+` then e = è

This key combination does not trigger the problem in Obsidian on iOS.

@Gadwood Effectivement, j’utilise un clavier QWERTY.

@rigmarole I am aware of the different possible methods of typing accents, but I am already used to this one and it’s very hard “memory-muscle wise” to change my typing habits just for a specific application. I was just wondering if this is a bug or if at least (if it’s linked to some Markdown languages) if we can turn it off, or otherwise If it’s possible for Obsidian to get rid of this impulsive behaviour of the ‘ symbol specially that I can’t see its utility.

That’s fine, but the way you’re talking makes it sound like there is no workaround. To others reading this, this is a workaround. You posted this in Help, and that is a workaround.

This definitely sounds like a bug. Especially if all other apps act differently, and especially if it ignores your settings when you turn off “auto pair”. So please feel free to post a bug report under Bug reports.

Thank you for your suggestion, this method definitely works to type accents without interfering with paired brackets. Like OP, I’m reluctant to change my typing method (old habits die hard). I will post this under Bug reports if there isn’t a post already.

Edit:

I see you guys have reported the issue in this post already:
The accent ‘ key is acting weirdly when typing in french (or other languages with accents)

It has been merged with this bug report:
Can’t turn off auto-pairing

Thank you!

1 Like