Workspace takes super long to load and then obsidian has to index my vault for half an hour and is very slow (Windows 11/ iCloud)

Steps to reproduce

  1. opening obsidian

Expected result

That the app opens and is ready to use

Actual result

Obsidian takes super long to index my vault (usually takes about 30-40 minutes to index …/51). Also, I noticed that I sometimes get the message that the file has been modified externally (which sets me back for 1 or 2 characters). And Obsidian creates about 30 (not accessible) file copies of the file I am working on when that happens. But I don’t know if these things have anything to do with each other.


  • Operating system: Windows 11, syncing via iCloud

  • Debug info:
    Obsidian version: v0.13.14
    Installer version: v0.12.15
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: on
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


I had a similar issue with iCloud on Windows 10 the other day.
Somehow those extra …(1).md notes can lock up the system. Just delete those extra files in your Windows file explorer including any in the hidden .obsidian folder.
Basically, your obsidian fault should show with a green checkmark

You might also have to kill/restart the icloud task or reboot your computer

1 Like

Moving clould releted issue to help section.
Iclould is notoriously to work poorly on win.

1 Like

I had a similar issue with iCloud on Windows 10 as well. It would create duplicate files with …(1).md and lock up obsidian each time. Perhaps pausing syncing can help?

I moved my files to OneDrive and it has been working great since then. However, I know it might not be an option for you.

1 Like

So just deleting those extra files didn’t do too much but I basically signed out and in of my icloud and the problem was solved. Also thanks to everybody for your solutions!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.