Workspace plugin scrolling pages to the bottom

I would like it to load pages from the top instead
e.g. the cursor pointing at first line
currently it seem to load at the bottom even if I save with cursor at the top

3 Likes

+1

I believe this is a bug and a regression from previous versions. Possibly in v1.0.0 with the introduction of tabs.

I frequently switch between layouts using the binding for Workspaces: Save and load another layout. This auto-scrolling behavior appears to only impact my tabs that are in edit mode (as opposed to preview). The behavior seems consistent regardless of where I have the cursor when I saved the layout.

Desired behavior:

  • [Ideal] Save scroll position in layout state
  • [Alt] Default to top of file

Current version: v1.0.3

Thanks!

2 Likes

in my case this happens when I have some dataview list or table

I am seeing this occur even with the Remember Cursor Position plugin enabled. In fact when loading a workspace, I can see the cursor itself may be at the top, but it still loads the file with a scroll toward the bottom. It should definitely default load to the top.

+1

It’s an issue for me too, and I’m using default Obsidian with no plugins. It never used to behave this way, so definitely recently introduced