Word wrap in markdown tables

Word wrap or line wrap dows not work in markdown tables, as they are displayed in Obsidian. Editing these tables is difficult, as it requires a lot of scrolling. I added an example below to test it

Feature request: enable word wrap for markdown tables in obsidian as well

Example:

Zeitschriftenname Kurzbeschreibung
Applied Cognitive Psychology Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat
Cognition and Instruction Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat
Computers in Human Behavior Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat
24 Likes

This feature would be very helpful. Working with large tables that don’t have line wrap is quite annoying since I often lose my position and have to scroll back and forth.

I was a little surprised this feature isn’t there, since regular lines and lists line wrap properly.


Update: what makes single-line tables difficult to work with for me, is that the End keyboard key jumps to the end of the visible text, but not jumps to the actual end of the line.

So when you press End, the text-typing cursor doesn’t go to the line’s end. :confused:

5 Likes

yes +1. I have one column that’s gigantic and 2 others that are super tiny, cause they don’t wrap at the same length. I don’t think it’s an issue so much if I could adjust column lengths myself to whatever I want to give importance to. I prefer that over it automatically wrapping at a certain length.

One Note does this well. I think tables need to be a bit more robust overall.

2 Likes

+1

I also encountered problems when dealing with long strings in tables. Currently as a work-around I use Latex, although it feels too cumbersome.

It would also be nice to have the ability to control the columns’ size (Ability to resize columns in tables).

Maybe add an extension to markdown, such as:

|col 1;50%|col 2;10px|…

or in a comment before the table

or maybe as a code block “language”, like mermaid:

; format options
|col1|col2|...
3 Likes

I… did not know this was a problem until it was a problem. Hopefully this won’t be that hard to implement as a setting at some point. +1.

2 Likes

I agree. This is particularly useful when making literature review tables.

1 Like

Hi all,

I just registered to add my voice to this petition. I use tables very often in my notes and seeing my rows extend to the width of their content is really a dealbreaker for my workflow. Hopefully there’s a way to fix this behaviour via css or a future app update.

Cheers!

1 Like

My current workaround is: open the file in Typora if there are wide tables…

3 Likes

My temporary way is: using table website “https://www.tablesgenerator.com/” then I copy to Obsidian.

I posted a way for how to make tables wrap here. It’s not exactly what you’re after, but perhaps it helps someone.

1 Like

+1

I consider this is a bug. But similar bugs thread about tables with long entries and wrapping problem got locked.

Anyways, as pointed out by others, long entries in tables are rather common. Definitions, translations, etc.