With new Properties feature, some notes aren't being pulled by dataview

I have searched and searched and searched for an answer to this question, but I still need help.

What I’m trying to do

I am trying to make a very simple dataview list to keep track of the books I read in a given year.

Things I have tried

There are several notes, like the one in the pictures below, that don’t get pulled when I use the dataview query below.

Here are three photos: (1) the Properties GUI display of the metadata I am trying to pull from, (2) the Source Mode view of the same data, and (3) the dataview query I created, which pulls lots of notes that fit the criteria.

I have tried triple checking that the property type of the missing note (“Answering Moral Skepticism (2023)”) and the property types of the notes that successfully get pulled are the same. I’ve gone in and out of Source Mode, and I cannot figure out why the note pictured above does not appear in my list.

Any help would be greatly appreciated.

Your properties type and status are currently of the list type, and then you need to do something like contains(type, "book") and not an ordinary equality operation which is used for non-list properties.


You are a hero. Thank you so, so much. I need to find out more about how to query different types in dataview. Seems like things were working fine before the Properties feature was released and I was just using YAML, so maybe I need to read up on the new types.

Thank you again for your help, I really appreciate it!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.