Windows High Contrast Mode impacts Obsidian UI Elements

Steps to reproduce

Enable Windows High Contrast: Shift + Alt + PrnScr

Expected result

Obsidian stays the same.

Actual result

All UI elements in Obsidian is effected by windows contrast


  • Operating system: Windows 10 Pro 21H1 Build 19043.1237

  • Obsidian version: V0.12.16 (Installer V0.12.15)

Additional information / Context

Used to use Windows Enterprise. I use High Contrast mode alot. When it is on, it does not impact Obsidian. PC just recently died. New Windows 10 Pro install, choco install’d all my programs, including obsidian. High Contrast Mode now turns all Obsidian UI elements black and white.

I’m not sure if it is Obsidian or my set up. Just posting, in case someone knows…

Before HCM

After HCM

Win 10 HCM settings

I don’t consider this a bug.

Ok sorry.
I remember Obsidian not subject to Window’s HCM. If this is not a bug, is this an intentional change then?


Update: I’ve downloaded the older version I used before (V0.12.12) on my win10pro. The same thing happens: all UI elements of Obsidian is effected.

It looks like it was the Win10Enterprise I was using who’s High Contrast Mode did not impact Obsidian. But this new Win10pro version I installed does.

I had thought that it was a change in Obisidian Versions that caused this issue. It is not.

Sorry about that @WhiteNoise.


Hi Welp!

I want to start using Obsidian and I’m suffering from the same phenomenon. This is something I care about a lot. Did you find any kind of solution or workaround?


I forgot to tag: @welp

Someone posted a solution, and it works for ANY exe you run on windows.

go to the properties of the .exe of your program, Then add
--disable-features=ForcedColors at the end of the target field. Example:
C:\ProgramFiles\Obsidian\Obsidian.exe --disable-features=ForcedColors

link to original Reddit post

1 Like

Yep, this is what I use now. I think I posted it on some other thread. Thanks anyway.

1 Like

My solution was to turn every other app into dark mode o.o

Chrome - Dark Reader
Word - Options → General → Office Theme : Black
Zotero - Dark Mode css
Adobe Acrobat - Ctrl K → Accessibility
VS Code - Dark mode theme
etc etc …