Window shadow in Linux

Hello everybody!

Faced the problem of displaying shadow under a window on Linux (XFCE).
The problem seems to be insignificant, but it greatly interferes visually as it merges with other windows in the back

Please help fix this.

Hi Alex,

Could you expand a little? What have you tried? Does this happen to other electron apps? Does this sound familiar?

1 Like

Thanks for answer. Yes, it looks similar. Shadows are enabled in the global window settings. For all other application windows, this problem does not exist.

As I understood from the material on your link, the problem is in the absence of window frames for Obsidian. Can this be fixed somehow or is the problem in the operating system itself?

Obsidian is an electron app, I think somewhere around v0.9.11 the frameless version was introduced (and therefore the system title bar was no longer available). I see two things that you can look into: your compositor/window manager should have some settings you can play with, and you can support Add option to enable/disable frameless mode.

I found another solution like this. Can I solve this problem similarly?

How I can vote for this option? Without shadows, I can’t work with app (I have poor eyesight)

Problem solved
For the XFCE GUI, the solution is in the Compton Composite Manager installation


  1. Disable effects in window settings;
  2. Install Compton;
  3. Add to autostart ;
  4. Reboot the system
1 Like

Just add a comment or like the FR! Glad to know it’s working!