Window position after undocking and going from dual to single monitor

Hi there, I have this very weird problem, I am not sure if it an Obsidian or Windows10 problem. I can’t seem to reproduce this with any other App though.

Problem setup: I use a SurfaceBook with an external Monitor. The problem occurs when I undock the laptop and start Obsidian with the laptop screen only.

Behavior: the Obsidian vault picker screen opens and I can choose an existing vault. The vault is opened (I can see it running in the taskbar), but it is not displayed on the laptop screen. It is as if it was logically running on the other (now detached) monitor.

Solutions I tried: Sofar I haven’t found a way to move the window back in view:

  • Win+Arrows doesn’t work
  • Cascade from the taskbar works only on visible windows
  • Close vault and reopen does now work

Workaround: only workaround sofar is to create a new Vault.

Any idea what else I could try?
Is there a Vault setting that could create this issue?


Likely to be a Windows issue. It’s a common problem.

Quite a few ways to tackle it.
Google bring lost window into focus. There’s a few you haven’t tried yet.

1 Like

The resolution change trick worked. Thanks. I still wonder why I am not seeing this with any other app I use, though.

I’ve had it with a number of different apps.
idk if some are more susceptible, but I’ve not observed a pattern.
Sometimes the window has even been outside the space of all the monitors.

I change from a multi-monitor to an inbuilt laptop display often, and see this issue all the time. It’s a Windows issue.