Why do I have an Obsidian folder inside an Obsidian folder

What I’m trying to do

Installing my first snippet I created a snippet folder, copied the snippet to it, and refreshed the snippets folder, but snippet w.as missing

Subsequently I found that I have an Obsidian folder inside an Obsidian folder. In the first there is an .obsidian folder, it has a snippets folder, and the snippet I installed is present, but there is no vault.

The other Obsidian folder is inside the first. It has a vault, the .obsidian folder is inside the vault, and it has a snippet folder, but the snippet missing

It is clear from the fact that the contents of the two folders are different, and that it was the folder that was consulted when I refreshed the snippets folder that the second is the operative Obsidian folder.

Things I have tried

I poked around in the Finder, noticed right away that there were two Obsidian folders one inside the other, and that the contents of the folders were different. That and the fact that it was the second folder that was consulted when I refreshed the snippets folder makes it clear that it is the operative folder.

But I’m curious why the snippet got installed in one folder but the other folder was the one referenced when the snippet folder was refreshed.

It’s because on one device you picked as vault root Obsidian and on another one you picked Obsidian\Obsidian

Thanks. You may be right operations on different devices will turn out to be the explanation. I’ve been impressed with the effectiveness of synchronization of desktop and mobile apps. Haven’t considered how I might have interfered with it.

But how did there get to be an Obsidian/Obsidian? When I start Obsidian I don’t pick a root. I must have done so outside of Obsidian at some point. Guess I need to be more careful what I do outside of Obsidian,

When you create a new vault on desktop you do; you choose a vault name and the place to put it. That’s the “root” of the vault.

Just a guess here, but when you created the ZK vault, you may have put it inside the Obsidian vault instead of in the “Obsidian” folder above it in your screenshot.

If you haven’t already, I would:

  1. Rename the Obsidian vault using the vault picker so it’s not confused with the Obsidian folder it’s in. You can use the three vertical dots next to the vault name in the vault picker.
  2. Move the ZK vault outside of the Obsidian-NEW-NAME vault using the same three dot menu.

1 Like

Thanks. Apologies for the delay. I’m on an extended vacation, trying to avoid getting caught up in stuff like this.

Anyway, you may well be right. I don’t remember what I did. The only thing I do remember is that ZK is not my first vault.

I am not clear about the distinction between the “Obsidian vault” and the “Obsidian folder.” I’ve assumed my only vault is “ZK.”

That aside, I thought I had solved the problem by going into Finder and removing everything in the inner Obsidian folder except the ZK vault and everything contained in it. But I see on checking just now that I still have an Obsidian folder in an Obsidian folder.

I will take time tomorrow to do what you suggest. (Is there a reason why doing it the way I did I still ended up with an Obsidian folder inside an Obsidian folder?)

With a little thinking I was able to distinguish the Obsidian vault from the Obsidian folder. When I renamed the Obsidian vault my system (macOS) wouldn’t allow it; the name would immediately return to what it had been. I went ahead and moved the ZK vault out of the Obsidian vault into the Obsidian folder. Then I deleted the Obsidian vault. Here’s the situation now.

Screen Shot 2023-05-13 at 10.59.37 AM

Interestingly, the new name stuck in the vault picker and the renamed vault continued to show up even after it was removed from the system. Also the “Reveal vault in finder” command revealed nothing. I went ahead and removed it from the list with the vault picker. Here’s what it looked like in the vault picker before and after renaming the Obsidian vault:



I have a concern: After using Finder to remove the Obsidian vault /library/mobile documents shows only the directories in /iCloud Drive. It is not possible to navigate through the file system to the Obsidian folder (and folders for many other apps). I fear some kind of troubling mismatch regarding what is where between Obsidian and macOS.

My suspicion was correct: Since deleting the contained Obsidian folder, which I, possibly mistakenly, took to be what was being referred to as the Obsidian vault, it is no longer possible to navigate to ZK, my actual Obsidian vault. Using the Finder, that is.

There is an enhanced third-party Finder called Path Finder, which I normally use. In it it is possible to navigate to the ZK vault. But because it seems Finder Rules for Obsidian it is not possible to open ZK in Obsidian.

I’m hoping Path Finder is right, that ZK does exist. But until I can find a way to direct Obsidian to it, Obsidian is now useless to me. It will not believe Path Finder.

No doubt I am in danger of wearing out my welcome here. Without the record of the posts above it is difficult for me to recall what the situation was, what I did, and the result. I think I can be brief.

I think the situation as of my last post–being unable to navigate to or open ZK, which I understood to be my only vault–is a result of lack of clarity on my part about the difference between the Obsidian folder and the Obsidian vault. I assumed that the contained folder was the vault.

I suspect that was a mistake. The fact that the system would not accept the rename I attempted, that it kept returning it to what it was before the change, was a clue to the fact that it was the Obsidian folder, not the vault. In any case, it was after I went ahead and deleted it that it became impossible to open ZK in Obsidian.

Being unable to navigate to or open ZK I created a new vault on my iPhone. It brings me back to square one: another case of an Obsidian folder in an Obsidian folder; in ~Library/Mobile Documents:

Screen Shot 2023-05-14 at 11.44.41 AM

Back at the beginning with this setup when I installed a snippet it got placed in the Obsidian vault instead of in the ZK vault where I was expecting it to go. Otherwise there were no problems – that I knew of.

For now I’m gonna leave this as it is. Until someone knowledgeable can explain how this is problematic and how to avoid the problem I’m gonna leave this as it is. Enough of a blind man trying to find his way with a stick.

One last question: Why are my vaults getting installed both in /iCloud Drive and ~/Library/Mobile Documents? I thought when I elected to have vaults stored in the cloud they were installed only there?

I’m not complaining. Just curious.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.