Whitespace after metadata/properties/YAML delimiter affects content

Steps to reproduce

  1. Write a metadata YAML section at the top of a file, e.g.
tags: ...
  1. Add spaces after the trailing dashes, e.g. "--- "

Expected result

The rest of the content parsed normally

Actual result

In edit mode markdown formats like links, code blocks, etc., appear as a part of the metadata section, but in view mode they appear correctly.


  • Operating system: Windows
  • Obsidian version: 0.12.5
  • We only consider bugs that are reproducible in the sandbox vault or a vault with no third-party plugins/no css snippets/default theme.
  • For Linux, we only accept bug reports that are reproducible with our Appimage package under Gnome or KDE (TBD)

Steps to reproduce

  • Open a sandbox vault
  • Create a new note with the following content:
  - tags

Uh-oh... obsidian doesn't like that
  • … And enter live preview

Did you follow the troubleshooting guide? [Y/N]


Expected result

Obsidian would either delete/ignore the extra whitespace:

--- <--- This one!

Actual result

In live preview, the entire text is shown:

In Reading mode, it straight up disappears:


	Obsidian version: v1.4.16
	Installer version: v1.4.16
	Operating system: #1-NixOS SMP PREEMPT_DYNAMIC Mon Oct 30 02:31:08 UTC 2023 6.6.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

  • I originally asked a question on discord asking if anyone knew about a plugin I recalled that would format frontmatter (properties) as a code block, as I wasn’t aware of the relatively new properties editor.
  • I’m running the NixOS (nixpkgs) version of obsidian, so I haven’t tested this on the appimage version - but I’m relatively certain it will be the same in both.

In case this wasn’t clear to anyone else: the extra whitespace is a single space at the end of the second ---, and it causes the source to be shown instead of the properties UI.

There should be no whitespace after the YAML delimiter. This bug as it was first reported a year ago is fixed.

The YAML section appears marked in red in LP because there is a syntax error (the extra white space) and no properties are parsed. Since no properties are parsed, there’s no relative block to show in reading mode.

First of all my apologies - I didn’t see this post in my perusal.

But secondly, I know why the whitespace didn’t work - I mainly made a bug report because I wanted to know if a QoL feature could be added - something to indicate why the properties section was parsed incorrectly. I know this may be either difficult or against the markdown spec, but it would be a nice QoL feature nonetheless.

Please, open a feature request.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.