Whisper plugin shows 'failed to parse 429'

What I’m trying to do

I’m trying to record and transcribe using the Whisper plugin. I have tried this on Mac desktop and iOS. I’m experienced with transcription generally and I use Whisper in other applications every day. But I would like to use it for note-taking in Obsidian, especially in the capable iOS mobile app.

Things I have tried

The plugin is installed with my Whisper AI key and seems to respond to the /Whisper start/stop dictation plugin or its hotkey. I repeat the action to ‘stop recording’. I don’t see a transcription and ‘failed to parse 429’ is shown.

429 means you are being rate limited, likely for attempting to transcribe more than the quota your subscription / usage tier / credit allows for.

See these issues on the Whisper plugin repo:

Alternatively, you / the plugin may be making too many requests:
https://platform.openai.com/docs/guides/rate-limits

That was helpful. I logged in to my OpenAI account and it was on the free tier which had lapsed. I did a modest top-up, tried the plugin and it worked well!

The only thing (tip perhaps) is whether, on iOS, there is a better way to start and stop transcription. Using the slash command /whisper for on and again /whisper for off is a bit clunky. I have a keyboard for my iPad but iPhone is more limited.

So I guess this was resolved then?
As for the other question, you could use the Commander plugin to add a button to the tab bar or mobile toolbar for the Whisper command you need.

Yes, I have discovered Commander and added a mic icon to the format bar. All good now, thank you so much for your help

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.