Where is main menu > developer console on Linux Mint?

What I’m trying to do

I have Obsidian on my Linux Mint 21.3 install, converting from Notion. I need to access the developer console to see the full name of three skipped items in the Notion zip file that are halting the conversion. I can’t find the developer console selection anywhere.

Things I have tried

I’ve checked every selection in my instance of Obsidian. No menu has the developer console, and in fact I can’t see the main menu with File, Edit, etc. at all. There is no visible Obsidian icon to click to display choices. The keyboard shortcuts for Windows and Mac don’t work, and looking in the shortcuts selection in settings I can’t find one for the developer console at all.

Does this link help you?

Console Log

1 Like

I think the shortcut is at the Electron level, so it doesn’t show up in the Obsidian hotkeys.

Just to be clear, you mean ctrl-shift-i doesn’t work? Can you test it in a Chromium browser and see if it works there? Trying to isolate if you have that key combo mapped to something different at the OS level.

1 Like

Ok, thanks for replying.
The link you gave me verified that I was indeed using the correct shortcut, even if in ignorance, because the particular web page I read that talked about shortcuts ONLY gave ones for Windows and Mac…not Linux. I tried both, so I should have had results since the Windows and Linux shortcut is the same. But it did not work then at all.

However…I’m on a different laptop now. I was using a Dell Latitude before and am on my Thinkpad now…and it works. Same Linux distro. So I really am not sure what’s going on, but the offending laptop is in my writing cabin, and it’s pouring rain here now, so I won’t be using the Dell until tomorrow or Tuesday. I’ll have to wait until then to Sherlock this out.

Thank you for the response, and I’ll mark this solved since I did just get the console to come up on my Thinkpad by using the indicated shortcut.

If you can’t get Ctrl-Shift-I working for whatever reason, the plugin GitHub - chrisgrieser/obsidian-theme-design-utilities: Some Utilities and Quality-of-Life Features for Designers of Obsidian Themes adds a command to toggle the Devtools.

1 Like

I could not figure out a way to reply to both of you simultaneously, but I wanted to thank you too for helping me.

Yes, right, Ctrl-Shift-i did NOT work on my Dell. It does on this Thinkpad. I use a Chromium browser (Vivaldi) on every computer I own. The Dell has acted a little…strange…today in other ways also, so I think there is a deeper issue involved I’ve got to sort out. Again, thanks!

Thank you for this response. I think I came across somewhere else earlier, but I had hoped to not have to go too far down the road for a solution. Now (if you read my comments above) I’m thinking my installation on the affected laptop has a deeper problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.