Where does Obsidian keep application-level data? --Windows 10

Things I have tried

Obsidian is keeping some data somewhere, as it remembers my vault when I uninstall/reinstall but I can not find it. (Windows 10)

What I’m trying to do

My ability to browse community plugins stopped working a few days ago and I’m trying to reset my system. Uninstall does not seem to fully reset Obsidian, so I’m thinking there is some place I need to do some cleanup.

Check out the docs.

docs? Do you mean help?

I did find the obsidian folder in AppData. I’ve tried running that instead of the windows installer. It does delete the app data. But on reinstalling, (1) it still remembers my vault and (2) I still can not browse community plugins again. (I’ve also searched the registry, but found only refences to the now deleted Obsidian director and the obsidian .exe file.


Thanks pmbauer, I appreciate the help.

Windows %APPDATA%\Obsidian\

Found and deleted. And also deleted by the Obsidian uninstaller. No change in behavior. The fact that Obsidian still remembers my vault is perhaps a read herring, as I’m really trying to get the community browse working again. And yes, I tried turning off windows defender (firewall) and rebooting to no avail.

I don’t think you deleted that.

Also if you can’t browse community plugins in the help vault, you most certainty have a network problem.

I do think this is a networking issue and not an obsidian settings issue. Before going to the settings panel, try popping up the inspector (Ctrl+Shift+I). That will let you see any errors in the console when you try to navigate. If you are on a corporate network, it’s possible they’ve blocked github access or perhaps you have a stale DNS address someplace preventing you from viewing the community plugins.

Inspector looks great. But it is showing no netword activity and no console errors when I click on browse. Indeed, the console is showing only one error:

[Calendar] Failed to find daily notes folder Error: Failed to find daily notes folder
at getAllDailyNotes (eval at (app.js:1), :271:15)
at Object.reindex (eval at (app.js:1), :972:36)
at getToday (eval at (app.js:1), :3933:14)
at Object.$$self.$$.update (eval at (app.js:1), :3975:28)
at init$1 (eval at (app.js:1), :627:8)
at new Calendar (eval at (app.js:1), :4000:3)
at CalendarView.onOpen (eval at (app.js:1), :4234:25)
at CalendarView. (app.js:1)
at app.js:1
at Object.next (app.js:1)

So I turned off the calendar plugin and restarted. Now no console errors. Browse still says only “Select a plugin to install or learn more about it.” with no plugins listed.

Forgot to say, no corp network or proxy. I’m at home.

I still think there is a networking issue, either your computer or LAN.
That is the most likely explanation. You could try installing obsidian on your phone and try installing plugins when on wifi vs your cell network to eliminate another variable. If it works on both wifi and cell, that would point to an issue on your PC.

Pulled out an old Thinkpad and installed Obsidian. Same problem. So it is not the PC. Remember, my ability to browse community plugins just stopped working one day and I was not doing anything at the time but the usual, Obsidian/Netflicks/skype. So I’m wondering if the issue is with my ISP, Spectrum.

I’ll try to find a 1-month free VPN offer and see if that does the trick.

there are plenty of free vpns (not just 1 month). try protonvpn.

Using a vpn did not fix my problem. I still can’t browse community plugins. So since this is not a configuration issue (fails on 2 pcs) nor a network issue (also fails on vpn) I guess it is a non-issue! (Though it still does not work.)

But I’m thinking it may be a pc issue. Yeah, since both PCs share my user data on MS OneDrive. :frowning:

I still don’t think you can rule out a network issue. That you are sharing your user configuration via one drive is another variable you could easily eliminate by creating another user account on one of your devices. Have you tried the suggestion to install obsidian on your mobile device?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.