When scrolling in big/long note, rest of note sometimes appears blank

When I scroll in a long note, I’ve noticed that sometimes the rest of the note, beyond the initially visible text, doesn’t load in, till you click.

Steps to reproduce

  1. have long note
  2. scroll
  3. rest of note doesn’t load
  4. click
  5. visible text loads
  6. scroll more
  7. have to click again

Expected result

automatically loading of text when scrolling?

Actual result

having to click when you scroll, otherwise text stays invisible that wasn’t initially on screen.


  • Operating system: Linux Mint
  • Debug info:
    Obsidian version: v0.13.23
    Installer version: v0.12.15
    Operating system: #29~20.04.1-Ubuntu SMP Fri Jan 14 00:32:30 UTC 2022 5.13.0-27-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Shimmering Focus
    Snippets enabled: 24
    Safe mode: off
    Plugins installed: 39
    Plugins enabled: 34
    1: Timeline
    2: Templater
    3: Tag Wrangler
    4: Tabout
    5: Style Settings
    6: Smart Typography
    7: Sliding Panes (Andy’s Mode)
    8: Settings Search
    9: Activity History
    10: Admonition
    11: Advanced Tables
    12: BUmBLe
    13: Custom window title
    14: Customizable Sidebar
    15: Cycle through Panes
    16: Dataview
    17: Excalidraw
    18: Find unlinked files and unresolved links
    19: Force note view mode
    20: Gallery
    21: Hide Sidebars When Narrow
    22: Kanban
    23: Link Headers Directly
    24: Maximise Active Pane
    25: Natural Language Dates
    26: Number Headings
    27: Obsidian Git
    28: Obsidian Tabs
    29: Outliner
    30: Ozan’s Image in Editor Plugin
    31: Page Count
    32: Pane Relief
    33: Remember cursor position
    34: Macros

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

This does NOT happen in a blank vault or in the help vault, even if I paste a lot of text and scroll. However it DOES happen in my main vault even if turn off ALL plugins and snippets, and use the default theme.
So I’m thinking it has to do with the size of the overall vault? I have 380 notes and 1 GB.
See this video for what I mean: Obsidian Scroll - YouTube

Disable plugins, themes, and css snippets. Restart Obsidian.
Post a screen recording of this happening.

Ok, so I disabled everything, restarted and it wasn’t happening anymore. Now I re-enabled everything, restarted, and now it’s also not happening anymore. So, I’m not sure what was happening, but as you can see it the linked video, it was indeed happening.
If it’s ok, I’d like to leave this open for now, because since I’m not sure what’s different now, it might reappear. Or if anyone has any ideas what might have been happening, that’d be cool :slight_smile: Thanks!

If you are able to reproduce this bug in the help vault or in your vault but with everything disabled (and restart), open a new bug report, attach a screen recording and a file where this is happening.

Ok, thank you :slight_smile:

Same issue. Tried disabling plugins, reloading etc but it’s an intermittent issue that is never present on initial load.

Obsidian version: v0.14.13
Installer version: v0.14.6
Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:37 PDT 2022; root:xnu-8020.121.3~4/RELEASE_ARM64_T6000 21.5.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: 80s Neon Fork
Snippets enabled: 0
Safe mode: off
Plugins installed: 52
Plugins enabled: 35
1: Divide & Conquer
2: Calendar
3: Cycle through Panes
4: Flashcards
5: Folder Note
6: Hotkey Helper
7: Key Promoter
8: MarginNote Companion
9: Maximise Active Pane
10: Media Extended
11: Meld Encrypt
12: Metadata Extractor
13: Admonition
14: Advanced URI
15: Auto Link Title
16: Completr
17: Extra Markdown Commands
18: Better File Link
19: File path to URI
20: Hotkeys for specific files
21: Hypothes.is
22: Outliner
23: Style Settings
24: Zoom
25: Obsidian42 - BRAT
26: Pane Relief
27: Periodic Notes
28: Quick Explorer
29: QuickAdd
30: Recent Files
31: Search on Internet
32: Settings Search
33: Sliding Panes (Andy’s Mode)
34: Templater
35: Paste URL into selection

We share:

  1. Cycle through Panes
  2. Maximise Active Pane
  3. Admonition
  4. Outliner
  5. Style Settings
  6. Settings Search
  7. Sliding Panes (Andy’s Mode)
  8. Templater

Disabling the Admonition plugin seems to have fixed the issue for me!

I’ll try that, thanks!

Unfortunately, I just got the error again despite having the Admonition plugin disabled; I’ll continue experimenting and post again with my findings.

Hi, have you solved this issue? I am experiencing the same bug.

Obsidian version: v0.15.9
Installer version: v0.15.9
Operating system: Windows 10 Enterprise LTSC 2019 10.0.17763
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: Minimal
Snippets enabled: 0
Restricted mode: off
Plugins installed: 7
Plugins enabled: 7
1: Better Word Count v0.8.1
2: Image auto upload Plugin v2.1.1
3: Minimal Theme Settings v5.3.2
4: Word Splitting for Simplified Chinese in Edit Mode v1.8.1
5: Style Settings v0.4.10
6: Editor Syntax Highlight v0.1.3
7: Sliding Panes (Andy’s Mode) v3.2.4

I have not heard anything about this or solved this. It does still happen every now and then. But no, no solutions yet.

It seems to be related to the sliding panes plugin. This bug has not happened since I disabled this plugin.

Added an issue to the sliding panes plugin github here