When pasting multiline content to new note, everything becomes filename

Steps to reproduce

  1. Copy this note in full:
This is meant to be the header

These are my notes.

### Related
- [[Other notes]]
  1. Press [CMD]+[N] for new note in Obsidian desktop app.
  2. Press [CMD]+[V] to paste the text.

Expected result

A new note / file with the filename This is meant to be the header.

Actual result

A new note where the filename is the entire content of the clipboard, newlines removed.


  • Operating system:
    MacOS 13.2 (22D49)

  • Debug info:
    I reproduced it in the sandbox vault:

Obsidian version: v1.1.12
Installer version: v0.15.9
Operating system: Darwin Kernel Version 22.3.0: Thu Jan 5 20:48:54 PST 2023; root:xnu-8792.81.2~2/RELEASE_ARM64_T6000 22.3.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

This is not a bug. What you’re expecting has not been implemented. Please submit a feature request using the template.

@RasmusM This is an expected behaviour in macOS that is common across other apps, as well. I believe the solution is not a fix in Obsidian, but rather to paste with Cmd-Shift-V (you can also use Paste and Match Style if you’re using the Menu bar or Paste as plain text if using the right-click contextual menu).

It sounds as though you are pasting into the top line of the note, which is actually just the file-name box.

Click below that and paste the text into the actual note and you should be sweet.

I suspect you’re answering something different.

Cmd-Shift-V inside the title of a note still puts all the content into the title.

As I understand it, RasmusM is asking for a way for the first line of a multi-line paste in to be the title (filename) of the note, and the remaining lines to be split into the contents of the note. So again, this should be a feature request. (If you’re already seeing this behaviour, I suspect you’re doing it with a community plugin.)

1 Like

Yes, you’re right. I addressed the wrong question. Thank you for the clarification.

This topic was automatically closed after 21 hours. New replies are no longer allowed.