When pasting code snippets note gets deleted

Steps to reproduce

Make a new note.
Paste this into it:

Code: php

<?php system($_REQUEST["cmd"]); ?>

Code: jsp

<% Runtime.getRuntime().exec(request.getParameter("cmd")); %>

Code: asp

<% eval request("cmd") %>

Wait a couple of seconds.

Did you follow the troubleshooting guide? [Y/N]


Expected result

Note will get deleted, and I get a fault from sync (not In sandbox tho).

Actual result

Both in my private vault and the sandbox vault, it deleted the note.


Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Windows 10 Home N 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 14
Plugins enabled: 14
1: Paste URL into selection v1.7.0
2: Recent Files v1.3.8
3: Settings Search v1.3.10
4: Plugin Update Tracker v1.5.2
5: Table of Contents v0.2.0
6: Emoji Shortcodes v2.2.0
7: Dataview v0.5.64
8: Banners v1.3.3
9: Homepage v3.6.0
10: Kanban v1.5.3
11: Advanced Tables v0.19.1
12: Buttons v0.4.19
13: Recipe Grabber v0.12.0
14: Metadata Menu v0.5.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This appears when the note is deleted:

this is not obsidian’s problem. It’s window’s antivirus who is deleting the file.

1 Like

The problem is just the first php line.

I see…
Regretting posting it as a bug now tho.
Solution was to filter out that file or the folder in windows defender… Thanks o/

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.