When I type [ ] for tasks it doesn't appear as a checkbox in the preview

I’ve been looking for a way to fix this issue, I’m new to obsidian and I don’t know what caused this. I really appreciate a solution for this, thank you.

I believe it must be in a list. So [ ] correctly renders as you see it; to make them checkboxes you have to have a - or * in front to make it a list. For example, - [ ].


To make a checkbox you need to type 5 characters (6 including the last space).
This felt very unintuitive.
So I setup a snippet in aText (My Text Expander) to turn “[]” into "- [ ] " only when I’m using obsidian. This works like a charm.

I’ve also set up “- - -” (Without space) to turn into “***” & Enter key.
This renders the cleaner separator, which doesn’t turn the previous text into heading.

Text expanders are amazing.


Tav I didn’t knew about text expanders! Thank You for sharing! It seems very useful.


You might be happy to learn that, by default, there is a hotkey to turn the current or selected lines into checkbox list formatting. Simply press ctrl + enter.

Once the formatting is created, the hotkey also works to toggle the checkbox as checked or unchecked. I love this hotkey.

As a side note, when I want to remove the formatting, I find it helpful to use a search and replace with search set to the 6 characters “- [ ] “ (without the quotes) and the replace set to nothing. To get rid of the checked boxes as well, you have to repeat this but with x between the brackets instead of a space.

Usually, I copy and paste the list into another word processing program to do this, but that is out of habit from before Obsidian had this feature. So, chances are you can do this within Obsidian just as well, but don’t quote me on that. I will double check and am glad to have realized this.



Thank you so much, it works! I didn’t know that there has to be a “-” in front

Thank you! I’m a beginner at this but I’ll look into text expander in the future

The hotkey works like a charm, it’s very convenient to do checkboxes now

Loving it, thank you!


Amazing. I’m gonna use this for toggling. Thanks

I know this is a late reply, but I had no idea that *** could work as a separator without turning the text before it into a heading! Great news! I thought this wasnt possible in markdown!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.