When I open Obisdian, the "Help" vault always opens first, why?

I am stuck! The “Help” Vault always opens first, then I have to switch to my PKM vault. Why??? Thank you

What I’m trying to do

What more information can you share?

What OS? And what version of Obsidian (plus what installer version)

Is your vault located in a syncing folder, like iCloud, OneDrive, Dropbox, etc.? There are sometimes issues with people syncing, where the settings files are getting duplicated.

Did this always happen? Or did it just start happening?

What OS? 10.15.7
Obsidian v0.13.14
iCloud for right now, but plan to move to Obsidian sync
It just started after I was looking for answers in the Help Vault. So every time I open Obsidian, the “Help” vault automatically opens.

Obsidian opens the last vault open.
So open another vault, close the Help vault and that ought to sort it.

  1. I opened Obsidian 2. Help Vault opened 3. Then opened my PKM vault 4. When I tried to close the app, it went back to the Help vault before being able to close the app.

You have to close the Help vault but not close the app. Keep the PKM vault open.


It worked!!! Thank you very much for all your help!!! One other question. I am a novice to Obsidian. Any course you could possibly recommend? Thank you again!

(EDIT: I was too late. Glad it worked!)

Can you please look in your /YourVault/.obsidian folder?

  1. And check to see if you have any duplicated files in there. That might indicate the problem.

  2. Although I think the list of vaults is stored in your Obsidian app settings:

~/Library/Application Support/obsidian/

If you look in there, do you see anything weird? If you rename that ~/Library/Application Support/obsidian/ folder to obsidianTemp it will reset your app preferences, and maybe that will fix the problem. And your local vault settings will remain untouched.

  1. Close Obsidian
  2. Go to ~/Library/Application Support/obsidian/
  3. Rename obsidian to obsidianTemp (Don’t delete it, just in case you want to put it back after.)
  4. Open Obsidian. You’ll need to add your vault back to your list of vaults.

If that fixes the problem, test around a bit, and then you should be able to delete obsidianTemp.

1 Like

Thank you for reaching out and helping me. Greatly Appreciated!!! One last question? I am a novice to Obsidian. Any courses you could possibly recommend? Thank you again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.