When 0 disk space, Obsidian delete all open notes

This bugs seems to be the same as 0-byte-file-again-note-completely-destroyed (which is closed)

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Decrease the disk drive (where the Obsidian notes are stored) to 0 free bytes
  2. Open a note
  3. Try to modify the note

Expected result

Prevent the open notes to be modified (the note should be in read-only)
Receive a strong visible warning message to say : “You cannot modify the note until there are more available disk space”

Actual result

The note is erased / blanked
There are several warning message which says that there is no more disk space


Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: #1 SMP PREEMPT_DYNAMIC Mon Feb 6 11:26:13 UTC 2023 6.0.19-4-MANJARO
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Atom
Snippets enabled: 3
Restricted mode: off
Plugins installed: 13
Plugins enabled: 7
1: Note Refactor v1.7.1
2: Advanced Tables v0.18.0
3: Dynamic Table of Contents v0.0.27
4: Outliner v4.1.1
5: Number Headings v1.10.0
6: Dataview v0.5.47
7: Templater v1.16.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I have met this bugs several times during the 18 previous months on “all” Obsidian version. I have lost several notes (now I am very carefully about this issue)

(forum.obsidian.md automatically delete the unchanged discussion. So it prevent anybody to answer or to share their experience after the timeout… That is why I need to duplicate an existing and similar discussion. I am sorry about that. This is the only forum I know which has this strange behavior.)

This is a different problem which was solved recently.

Regarding the 0 disk space and other I/O problems, we have the file recovery plugin.

We could add something specific for disk full, feel free to open a feature request for that.

I don’t know how the recover plugin works… Maybe you can help ?

I followed your advice in creating this feature request

Thanks :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.