What to do when a community plugin cannot be installed?

I am new to Obsidian and have only worked with very few core plugins and two community plugins. I now cannot install another community plugin and wonder what is the right way to proceed.

Things I have tried

I tried to install the community plugin Advanced Slides (v1.13.0), and get a pop-up window with the message ‘Failed to install plugin “Advanced Slides”.’ However, directly afterwards, I could install and enable the community plugin Dataview.
I attach what the console shows for these two items.

What is the correct way to proceed now? I have tried on a new vault as well. I have tried with the AppImage and with Snap (each v0.14.6). I am on Ubuntu 22.04.

What I’m trying to do

I am guessing you mean version 1.12.9 of the Advanced Slides plugin, version 1.13.0 does not exist.

I checked the plugin page, and everything seems to be in order.
I could install version 1.12.9.

Now everything works - with Snap, with AppImage and for new vaults and even my productive ones. I did not touch on my network configuration!!

@joethei Thanks a lot for this quick reaction. I now suspect that there was a temporary server-side misconfiguration for that plugin - showing up by that version number. I ought to have taken a screenshot of that number as well…

1 Like

Capture d’écran du 2022-06-06 12-44-38
comes up again after reverting my Obsidian installation back to a Snap. And installation fails.

And I am again back on AppImage, and 1.13.0 installs fine and can be enabled.
I think there is a problem when version changes of plugins create so many worries on the side of a normal user.

Seems to me that 1.13.0 was deployed, and then removed again before you clicked on install.
Now its deployed again, right after you reverted to the Snap.

There is some caching on GitHub’s side that might be the cause of this, I don’t think that much can be done on the side of Obsidian.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.