Weird error: ENOENT

Things I have tried

Nothing, because I have no idea what to do!

What I’m trying to do

Get rid of that error!

I have no clue what that error means. It shows up when I use the Developer Tools and it worries me.

Anyone an idea why this is happening and how I can fix this?

Thanks in advance :slight_smile:

Hi @FiekeB, the error is generated when trying to scan the following folder /Users/Fieke/Desktop/Fie's MackBook Vault/css-snippets. Maybe that folder doesn’t exist. Copy that path and open it from a File explorer app to confirm. BUT Obsidian CSS snippets are stored in “vault/.obsidian/snippets”…

Your screenshot is somehow weird. It shows source files like index.ts and directories like “controller”. This is not the same I see when I open Devtools in Obsidian:

image

How did you get there? How did you installed the app? Please the detail the steps to reproduce.

1 Like

The weird thing is that my Mac Finder shows me that everything is where it is. Or so I think…

I have 3 identical vaults that I sync with an external sync app. All of them behave like they should, as far as I know. Snippets work too.

  • One is in/on my Desktop Folder of my MacBook. (this one gives the error)
  • One on an external hard drive
  • One in iCloud

I have never seen this error before, in any of my vaults. Below you can see the vault with the error, as you can see there isn’t even a folder called “css-snippets”, just a “snippets” - while I now see that its folder should be called css-snippets and be in the root of my vault. Weird thing: all my snippets have always worked, even though they were in the “wrong” place in a folder with a “wrong” name!

But, I relocated and renamed the folder and it is now indeed in the root and called css-snippets and now that error is indeed gone. One problem solved!

The other error remains, the one yelling about something or other being wrong with .json input

DevTools failed to load SourceMap: Could not parse content for app://obsidian.md/pickr.min.js.map: Unexpected end of JSON input

I found the culprit: in my specific situation, on my specific MacBook, MG Meyers plugin “Style settings” does not play nice with Obsidian.

I turned all 3rd party plugins off and then back on, one by one. DevTools updated instantly as I was doing so, and all was well until I turned the plugin “Style Settings” on. It gave the same error as above “DevTools failed to load source map…” blahblah.

I don’t know why, because I have not installed any new plugins lately nor changed themes or anything.

Okay, so now the pugin CSS Snippets is behaving weird. Above I stated they were in a folder .obsidian/snippets and that this had always works, apart from that weird error (the one in red font, in the top picture of this topic) I got that said "Uncaught (in promise) Error: EN0ENT: no such file or directory, scandir ‘/Users/Fieke/Desktop/Fie’s MacBook Vault/css-snippets’

In the plugin’s description, it also says that the snippets should be in a folder css-snippets in the vault’s root. That’s where they were not, so I made such a folder in my root and moved all my snippets there.

I restarted Obsidian and went to Settings to turn the snippets back on, figuring after such a move, that would be needed. What do you know…NO snippets to be seen in Settings! It said, your snippets need to be in .obsidian/snippets !

But when I put them there, I can turn them on in settings and they all work, but I get this weird error!!!

Okay…ERROR was caused because I did not know this plugin CSS Snippets is obsolete because it is now in the CORE of Obsidian. So it was me installing an extra instance of it, that was causing the error.

Maybe REMOVE this plugin from the 3rd party plugins we can turn on from inside Obsidian? @Lithou ?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.