Weird character menu appearing when using l key to navigate using vim bindings

What I’m trying to do

A weird character menu appears when I navigate using l key using vim bindings on the desktop client on Mac
Screenshot 2023-12-31 at 3.38.07 PM

Things I have tried

Switching the text font.

I encountered the same issue. Upon investigation, I discovered that this behavior is related to a macOS feature called the ‘Accent Menu.’

You can disable it by executing the following command:

defaults write -g ApplePressAndHoldEnabled -bool false

After restarting Obsidian, the menu should no longer appear. Hope this helps!