VoiceOver Issues on macos

Steps to reproduce

  • Enable VoiceOver.
  • Attempt to Navigate the app by keyboard.
  • Attempt to open another vault.

Expected result

  • See the option to expand the right panes.
  • Be able to close the dialog box without opening a new vault.
  • Be able to tell the difference between the left and right Expand/Collapse buttons. Right now they only say Expand or Collapse which is not enough when navigating by keyboard.

Actual result

  • The button to expand the right panes is invisible. You need to hunt for the Expand button on the right side with the mouse right now.
  • The dialog to open another vault can’t be closed until you find the close button with the mouse pointer. You should be able to close the window with Escape or Cmd-W or navigate to the close button with normal VoiceOver keyboard navigation. You need to hunt for the close button with the mouse right now.

Environment

  • Operating system: macOS Big Sur 11.2.3
  • Obsidian version: 0.11.13

Additional information

1 Like

There is already FR to improve keyboard navigation of some modal windows.

I am gonna move this to FR as well for VoiceOver.
I hope we can get better at accessibility in the future.

1 Like

That sounds good. It’s not too bad at the moment and really appreciate how accessible it already is.

1 Like

I’m using Voice Control on my Mac today because my RSI is acting up.

However, it looks like I can’t use Voice Control with Obsidian. I’ve defaulted to talking to Drafts to input text and then cutting and pasting into Obsidian.

Luckily, I don’t need Voice Control every day, but other users might. Please add this to the Roadmap if possible.

Let me know if I’ve missed a setting to turn this on in Obsidian.

Thank you.

6 Likes

Commenting just to strongly communicate an upvote.

Related: Services item in editor menu on Mac.

2 Likes

Merged another thread.

Accessibility is critical and should be further implemented.

1 Like

Another issue with VoiceOver enabled is the inability to type anything into the search box. The error says “table not found” until you turn off VoiceOver so you can type in a search term.

Navigating settings using VoiceOver many controls cannot be accessed/enabled/disabled

Steps to reproduce

Start Voiceover (Cmd-F5)
Start Obsidian
Using VoiceOver keyboard commands navigate to and Open Settings
Using VoiceOver keyboard commands navigate to and select Core Plugins
Using VoiceOver keyboard commands navigate to and select the Sync plugin
From this point there seems to be no way to toggle the setting on or off

Expected result

That the plugin can be activated or deactivated as desired

Actual result

No control of the setting can be accessed via VoiceOver actions

Environment

  • Operating system: Mac OS Big Sur 11.4
  • Obsidian version: 0.12.5

Additional information

This is consistent across all settings; the actual controls are not accessible from VoiceOver.

3 Likes

I’m late to this party but I strongly up vote this feature request.

For background, I was excited to discover obsidian and try it on my Mac, but unfortunately it doesn’t support the speech recognition built into MacOS.

Actually, it’s more puzzling than that. MacOS allows you to do ad hoc dictation by pressing the command key twice. That works fine with obsidian.

But you can also turn on Voice Control to control your Mac with your voice, which saves a great deal of wear and tear on your carpal tunnel. But it disables the ad hoc dictation described above and replaces it with a more robust version of speech recognition. That’s a good thing for most apps other than obsidian, but for some reason obsidian doesn’t support that speech recognition. Which means I have to turn off voice control in order to dictate into obsidian. Sadly, that’s a nonstarter for me and my aging hands.

Would that I had the technical chops to provide a solution for this but I don’t. That said, I’d love to see a fix in some future version of obsidian.

1 Like

In brief, when reading any document with VoiceOver (VO) that’s longer than the screen, that is to say, the document can not all fit on the screen at once, VO cannot ‘see’ anything not on screen. When this happens it prevents scrolling in the document and prevents VO form reading it.

Steps to reproduce

  • Have a longish document.
  • Have VoiceOver On
  • Engage with the editor portion
  • VO Navigate Down through text

Expected result

As VO reads text, it scrolls the document until it reaches the bottom/end of content.

Actual result

VO stops reading at the end of the window. The document does not scroll. VO menus and searches do not recognize anything not on screen.

Environment

macOs Big Sur
Obsidian 12.0


Obsidian is mostly accessible with VoiceOver, but could be really improved. This particular issue makes using Obsidian essentially impossible as longer documents just can’t be read. The notes landscape for folks with vision issues is… barren. Experts have advised me to use macOs’s TextEdit for my all my notes and documents (I’m a PhD student). I hope that gives you a sense of why this sort of thing matters. I’m happy to be as engaged in the resolution and improvement process and would be helpful / supportive. Obsidian is just amazing, and I love it. Thanks to devs for the hard and creative work!

search tags: screen reader, voiceover, voice, over, blind, low vision, access, accessibility, mac

does this happen in editor or in preview or both?

THis is likely due to Obsidian optimization to render only what is on view. It makes Obsidian snappy on very large documents.

Sorry for the long term reply - I happens in both modes.

It makes a ton of sense for this functionality - it just makes it unusable. I cannot express how much better Obsidian is - I’ve had to ‘resort’ to using Roam. I’d love to do some testing and help support access however I can!

Have you had the chance to test a recent version of Obsidian?