VIM sequence broken

The following scenario worked until today :point_down:

Steps to reproduce

  1. Enable vim mode
  2. Enter the following command β€œ: norm o<ESC>k”

Did you follow the troubleshooting guide? [Y]

Expected result

Create empty line below current cursor position

Actual result

Creates empty line below, and writes β€œ<ESC>k” to the editor


Obsidian version: v1.4.5
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.4.0: Mon Mar 6 20:59:58 PST 2023; root:xnu-8796.101.5~3/RELEASE_ARM64_T6020 22.4.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 21
Plugins enabled: 21
1: Vimrc Support v0.9.0
2: Editor Syntax Highlight v0.1.3
3: Mind Map v1.1.0
4: Advanced Tables v0.19.1
5: Advanced Slides v1.20.0
6: Kanban v1.5.3
7: Icon Folder v2.1.2
8: Better Word Count v0.9.6
9: Highlightr v1.2.2
10: Pandoc Plugin v0.4.1
11: Omnisearch v1.15.0
12: Dictionary v2.22.0
13: Global Search and Replace v0.3.0
14: DB Folder v3.4.0
15: Dataview v0.5.56
16: Relative Line Numbers v2.0.1
17: Excalidraw v1.9.10
18: Settings Search v1.3.8
19: Paste URL into selection v1.7.0
20: Reminder v1.1.15
21: Image Inserter v0.6.2

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Try to execute the following: norm o<Esc>k – pay attention to the spelling of the escape key. :wink:


Whoops you’re right. Thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.