Vim mode indented long link cursor issue

Steps to reproduce

  • Create new vault/use existing vault.
  • Enable vim mode.
  • Start typing a list, and in a sub-bullet (intended once or more), type a [link_with_a_long_link_text_that_uses_underscores_or_another_non_word_breaking_character_such_as_this_one_some_extra_text_on_the_end_to_make_it_long_enough](, or open the attached Markdown document. The key is that the link gets pushed onto the line below where the bullet is.
  • Move your cursor in normal mode (press Esc) to the start of the bullet point with the link.
  • Use h and l to move around, and observe how the cursor moves to the wrong spot.

Did you follow the troubleshooting guide? [Y/N]

Yes, tried in my own vault and in the sandbox vault

Expected result

The cursor shouldn’t overlap characters.

Actual result

The cursor overlaps with other characters that it shouldn’t. See the screen recording for a demo.


	Obsidian version: v1.5.8
	Installer version: v1.4.16
	Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:54:51 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6030 23.2.0
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

markdown file with problematic link (601 Bytes)
screen recording

does it happen without vim mode?