Vim key bindings and styles breaks when i type the ´ (acute accent) character in the vim mode

Steps to reproduce

  1. Enable Vim key bindings in Obsidian.
  2. Try to type an acute accent (´).
  3. Note that Obsidian tries to autocomplete with another acute accent and the Vim key bindings stop working.
  4. Additionally, observe that the styling doesn’t show up.

Did you follow the troubleshooting guide? [Y/N] Y

Expected result

I expect Obsidian to handle typing acute accents correctly while using the Vim key bindings, with no impact on styling or key bindings.

Actual result

Obsidian tries to autocomplete acute accents and the Vim key bindings stop working, affecting the styling.

Environment

  • Obsidian version: 1.5.11
  • Installer version: 1.5.3
  • Tried Obsidian sandbox
  • Problem occurs only with Vim key bindings enabled

Additional information

No additional information provided.