Vim inserting unwanted characters when scrolling with j or k

Unfortunately I can’t seem to reproduce this bug anymore, but I thought I would make this post just in case anyone else encounters it. The gif I captured below shows the bug in action. I “fixed” it by restarting obsidian and toggling live preview off and on.


When scrolling through a file with j or k in vim mode, extra characters get inserted into the document.

Steps to reproduce

  1. Open up a longer file such as this one (shown in gif below) (3.2 KB)

  2. Scroll to bottom with ‘j’ key.

  3. Scroll back to the top with ‘k’ key.

Expected result

Nothing. Document should remain unchanged.

Actual result

When scrolling down, j’s seem to be inserted randomly before line breaks. And when scrolling up, it gets “stuck” and starts inserting k’s.
vim_scroll_bug

Environment

  • Operating system: Windows 10
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.13.19
    Installer version: v0.12.10
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Atom
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 10
    Plugins enabled: 9
    1: Calendar
    2: Kanban
    3: Spaced Repetition
    4: Advanced Tables
    5: Templater
    6: Natural Language Dates
    7: Obsidian Git
    8: Shortcuts extender
    9: File Tree Alternative Plugin

Additional information

I am unsure if this is specifically related to the new live preview editing update, but it seemed to fix itself once I restarted obsidian and toggled live preview off and on again.

Post a new bug report if you can reproduce this in the help vault